POJ - 1195 Mobile phones —— 二维线段树 区间更新点查询

Mobile phones

Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 21877 Accepted: 10176

Description

Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports the change in the number of active phones to the main base station along with the row and the column of the matrix. 

Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area. 

Input

The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on a separate line, and consists of one instruction integer and a number of parameter integers according to the following table. 


The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and 0 <= Y <= 3. 

Table size: 1 * 1 <= S * S <= 1024 * 1024 
Cell value V at any time: 0 <= V <= 32767 
Update amount: -32768 <= A <= 32767 
No of instructions in input: 3 <= U <= 60002 
Maximum number of phones in the whole table: M= 2^30 

Output

Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer as a single line containing a single integer to standard output.

Sample Input

0 4
1 1 2 3
2 0 0 2 2 
1 1 1 2
1 1 2 -1
2 1 1 2 3 
3

Sample Output

3
4

区间更新点查询

卡内存卡的比较死...1024*1024*4/1024恰好是规定的内存限制

看discuss说把原本开4倍的改成2倍,就过了

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <cmath>
#include <vector>
#include <bitset>
#define max_ 1024
#define inf 0x3f3f3f3f
#define ll long long
#define les 1e-8
#define mod 364875103
using namespace std;
int tree[max_*2][max_*2];
int n;
void upda(int i,int x,int nl,int nr,int v,int id)
{
    if(nl==nr)
    {
        tree[id][i]=max(0,tree[id][i]+v);
        return;
    }
    int mid=(nl+nr)>>1;
    if(x<=mid)
    upda(i<<1,x,nl,mid,v,id);
    else
    upda(i<<1|1,x,mid+1,nr,v,id);
    tree[id][i]=tree[id][i<<1]+tree[id][i<<1|1];
}
void up(int i,int x,int nl,int nr,int id)
{
    tree[id][i]=tree[id<<1][i]+tree[id<<1|1][i];
    if(nl==nr)
    return;
    int mid=(nl+nr)>>1;
    if(x<=mid)
    up(i<<1,x,nl,mid,id);
    else
    up(i<<1|1,x,mid+1,nr,id);
}
void updata(int i,int x,int y,int nl,int nr,int v)
{
    if(nl==nr)
    {
        upda(1,y,1,n,v,i);
        return;
    }
    int mid=(nl+nr)>>1;
    if(x<=mid)
    updata(i<<1,x,y,nl,mid,v);
    else
    updata(i<<1|1,x,y,mid+1,nr,v);
    up(1,y,1,n,i);
}
int que(int i,int l,int r,int nl,int nr,int id)
{
    if(l==nl&&r==nr)
    {
        return tree[id][i];
    }
    int mid=(nl+nr)>>1;
    if(r<=mid)
    return que(i<<1,l,r,nl,mid,id);
    else if(l>mid)
    return que(i<<1|1,l,r,mid+1,nr,id);
    else
    return que(i<<1,l,mid,nl,mid,id)+que(i<<1|1,mid+1,r,mid+1,nr,id);
}
int query(int i,int l,int r,int nl,int nr,int dl,int dr)
{
    if(l==nl&&r==nr)
    {
        return que(1,dl,dr,1,n,i);
    }
    int mid=(nl+nr)>>1;
    if(r<=mid)
    return query(i<<1,l,r,nl,mid,dl,dr);
    else if(l>mid)
    return query(i<<1|1,l,r,mid+1,nr,dl,dr);
    else
    return query(i<<1,l,mid,nl,mid,dl,dr)+query(i<<1|1,mid+1,r,mid+1,nr,dl,dr);
}
int main(int argc, char const *argv[]) {
    int m;
    while(scanf("%d",&m)!=EOF)
    {
        if(m==3)
        break;
        if(m==0)
        {
            scanf("%d",&n);
            memset(tree,0,sizeof tree);
        }
        else if(m==1)
        {
            int x,y,v;
            scanf("%d%d%d",&x,&y,&v);
            x++;
            y++;
            updata(1,x,y,1,n,v);
        }
        else if(m==2)
        {
            int x1,x2,y1,y2;
            scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
            x1++;y1++;
            x2++;y2++;
            printf("%d\n",query(1,x1,x2,1,n,y1,y2));
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值