1016. Phone Bills (25)

1016. Phone Bills (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (<= 1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word "on-line" or "off-line".

For each test case, all dates will be within a single month. Each "on-line" record is paired with the chronologically next record for the same customer provided it is an "off-line" record. Any "on-line" records that are not paired with an "off-line" record are ignored, as are "off-line" records not paired with an "on-line" record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:
10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line
Sample Output:
CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

提交代码

题解: 给你n个人的通话记录,然后给你每个时间段的话费单价,让你求出每个用户每个月的电话账单

题意:读入这n个人的通话记录, 我们可以先排个序,然后一点一点模拟处理就好了,注意,小数部分一定要打印 "%02d",否则会答案错误.


#include <cstdio>
#include <string>
#include <iostream>
#include <algorithm>

using namespace std;
int charge[30];

struct node{
    string name, time, state;
    bool operator<(const node & X) const{
        if (name == X.name)
            return time < X.time;
        return name < X.name;
    }
}Node[1010];

int get_time(const string & str) {
    int total_time = 0;
    total_time = (str[9] - '0') * 10 + (str[10] - '0');
    total_time = ((str[6] - '0') * 10 + (str[7] - '0')) * 60 + total_time;
    total_time = ((str[3] - '0') * 10 + str[4] - '0') * 24 * 60 + total_time;
    return total_time;
}

int get_charge(int begin_time, int end_time) {
    int total_charge = 0;
    if (begin_time % 60 != 0) {
        total_charge += charge[(begin_time / 60) % 24] * (60 + begin_time / 60 * 60 - begin_time);
        begin_time = 60 + begin_time / 60 * 60;
    }

    for(; begin_time <= end_time; begin_time += 60)
        total_charge += charge[(begin_time / 60) % 24] * 60;
    if (begin_time > end_time)
        total_charge -= charge[(end_time / 60) % 24] * 60 - charge[(end_time / 60) % 24] * (end_time - end_time / 60 * 60);
    else
        total_charge += charge[(end_time / 60) % 24] * (end_time - end_time / 60 * 60);

    return total_charge;
}

int main() {
    for (int i = 0; i < 24; ++i)
        scanf("%d", charge + i);

    int n;
    scanf("%d", &n);

    for (int i = 0; i < n; ++i) {
        cin >> Node[i].name >> Node[i].time >> Node[i].state;
    }

    sort(Node, Node + n);
    string month(Node[0].time.begin(), Node[0].time.begin() + 2);
    string name;
    int cur_charge = 0;

    for (int i = 1; i < n; ++i) {
        if (Node[i].state == "off-line" && Node[i - 1].state == "on-line" && Node[i].name == Node[i - 1].name) {
            if (Node[i].name != name) {
                if (name != "")
                    printf("Total amount: $%d.%02d\n", cur_charge / 100, cur_charge % 100);
                cur_charge = 0;
                name = Node[i].name;
                cout << name << " " << month << endl;
            }

            int total_time = get_time(Node[i].time) - get_time(Node[i - 1].time);
            int total_charge = get_charge(get_time(Node[i - 1].time), get_time(Node[i].time));
            cur_charge += total_charge;
            cout << Node[i - 1].time.substr(3, 8) << " "
                 << Node[i].time.substr(3, 8) << " "
                 << total_time << " $";
            printf("%d.%02d\n", total_charge / 100, total_charge % 100);
        }
    }
    printf("Total amount: $%d.%02d\n", cur_charge / 100, cur_charge % 100);

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值