LightOJ 1422 Halloween Costumes

Halloween Costumes


Time Limit: 2000MS      Memory Limit: 32768KB      64bit IO Format: %lld & %llu

Description

Gappu has a very busy weekend ahead of him. Because, next weekend is Halloween, and he is planning to attend as many parties as he can. Since it's Halloween, these parties are all costume parties, Gappu always selects his costumes in such a way that it blends with his friends, that is, when he is attending the party, arranged by his comic-book-fan friends, he will go with the costume of Superman, but when the party is arranged contest-buddies, he would go with the costume of 'Chinese Postman'.

Since he is going to attend a number of parties on the Halloween night, and wear costumes accordingly, he will be changing his costumes a number of times. So, to make things a little easier, he may put on costumes one over another (that is he may wear the uniform for the postman, over the superman costume). Before each party he can take off some of the costumes, or wear a new one. That is, if he is wearing the Postman uniform over the Superman costume, and wants to go to a party in Superman costume, he can take off the Postman uniform, or he can wear a new Superman uniform. But, keep in mind that, Gappu doesn't like to wear dresses without cleaning them first, so, after taking off the Postman uniform, he cannot use that again in the Halloween night, if he needs the Postman costume again, he will have to use a new one. He can take off any number of costumes, and if he takes off k of the costumes, that will be the last k ones (e.g. if he wears costume A before costume B, to take off A, first he has to remove B).

Given the parties and the costumes, find the minimum number of costumes Gappu will need in the Halloween night.

Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case starts with a line containing an integer N(1 ≤ N ≤ 100) denoting the number of parties. Next line contains N integers, where the ithinteger ci(1 ≤ ci ≤ 100) denotes the costume he will be wearing in party i. He will attend party 1 first, then party 2, and so on.

Output

For each case, print the case number and the minimum number of required costumes.

Sample Input

2

4

1 2 1 2

7

1 2 1 1 3 2 1

Sample Output

Case 1: 3

Case 2: 4


区间DP法,f[i,j]表示i~j区间用的衣服的最少数量

对于状态转移有最简单的方法 f[i][j]=f[i][j-1]+1即直接穿上一件衣服满足s[j]

或者 f[i][j]=min(f[i][k]+f[k+1][j]) (s[i]==s[k])即当i与k相同时,可以从k处断开


代码如下

#include<cstdio>
#include<cstring>
#include<iostream>

using namespace std;

	int T,n;
	int s[150];
	int f[150][150];

int main()
{
	scanf("%d",&T);
	for (int t=1;t<=T;t++)
	{
		scanf("%d",&n);
		memset(f,0,sizeof(f));
		for (int i=1;i<=n;i++)
		{
			scanf("%d",&s[i]);
			f[i][i]=1;
		}
		
		for (int l=2;l<=n;l++)
		{
			for (int i=1;i<=n-l+1;i++)
			{
				f[i][i+l-1]=f[i][i+l-2]+1;
				for (int j=i;j<i+l-1;j++)
				{
					if (s[i+l-1]==s[j])
					{
						f[i][i+l-1]=min(f[i][i+l-1],f[i][j]+f[j+1][i+l-2]);
					}
				}
			}
		}
		
		printf("Case %d: %d\n",t,f[1][n]);
	}
	
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值