LightOJ_1422_HalloweenCostumes

Halloween Costumes
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

Gappu has a very busy weekend ahead of him. Because, next weekend is Halloween, and he is planning to attend as many parties as he can. Since it's Halloween, these parties are all costume parties, Gappu always selects his costumes in such a way that it blends with his friends, that is, when he is attending the party, arranged by his comic-book-fan friends, he will go with the costume of Superman, but when the party is arranged contest-buddies, he would go with the costume of 'Chinese Postman'.

Since he is going to attend a number of parties on the Halloween night, and wear costumes accordingly, he will be changing his costumes a number of times. So, to make things a little easier, he may put on costumes one over another (that is he may wear the uniform for the postman, over the superman costume). Before each party he can take off some of the costumes, or wear a new one. That is, if he is wearing the Postman uniform over the Superman costume, and wants to go to a party in Superman costume, he can take off the Postman uniform, or he can wear a new Superman uniform. But, keep in mind that, Gappu doesn't like to wear dresses without cleaning them first, so, after taking off the Postman uniform, he cannot use that again in the Halloween night, if he needs the Postman costume again, he will have to use a new one. He can take off any number of costumes, and if he takes off k of the costumes, that will be the last k ones (e.g. if he wears costume A before costume B, to take off A, first he has to remove B).

Given the parties and the costumes, find the minimum number of costumes Gappu will need in the Halloween night.

Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case starts with a line containing an integer N(1 ≤ N ≤ 100) denoting the number of parties. Next line contains N integers, where the ith integer ci(1 ≤ ci ≤ 100) denotes the costume he will be wearing in party i. He will attend party 1 first, then party 2, and so on.

Output

For each case, print the case number and the minimum number of required costumes.

Sample Input

2

4

1 2 1 2

7

1 2 1 1 3 2 1

Sample Output

Case 1: 3

Case 2: 4


非常奇怪的一道区间dp

这个题目的状态转移

当中间和起点穿的衣服相同的时候相当于少去起点的情况,因为这个第一件可视作穿上没有脱过

   中间和起点穿的衣服不相同的时候相当与比少去起点多穿一件衣服

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;

const int M=105;
const int IN=1000;
int pa[M];
int dp[M][M];

int main()
{
    //freopen("1.in","r",stdin);
    int t;
    int n;
    int ca=1;
    scanf("%d",&t);
    while(t--)
    {

        scanf("%d",&n);
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
            scanf("%d",&pa[i]);
        for(int i=1;i<=n;i++)
            dp[i][i]=1;
        for(int l=2;l<=n;l++)
        {
            for(int st=1;st<=n-l+1;st++)
            {
                int co=IN;
                for(int mi=st;mi<=st+l-1;mi++)
                {
                    if(mi!=st&&pa[mi]==pa[st])
                        co=min(co,dp[st+1][mi]+dp[mi+1][st+l-1]);
                    else
                        co=min(co,dp[st+1][mi]+1+dp[mi+1][st+l-1]);
                    //cout<<"l "<<l<<" st "<<st<<" mi "<<mi<<" dp "<<co<<endl;
                }
                dp[st][st+l-1]=co;

            }
        }
        printf("Case %d: %d\n",ca,dp[1][n]);
        ca++;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值