LightOJ 1422 Halloween Costumes(区间DP )

Description

Gappu has a very busy weekend ahead of him. Because, next weekend is Halloween, and he is planning to attend as many parties as he can. Since it's Halloween, these parties are all costume parties, Gappu always selects his costumes in such a way that it blends with his friends, that is, when he is attending the party, arranged by his comic-book-fan friends, he will go with the costume of Superman, but when the party is arranged contest-buddies, he would go with the costume of 'Chinese Postman'.

Since he is going to attend a number of parties on the Halloween night, and wear costumes accordingly, he will be changing his costumes a number of times. So, to make things a little easier, he may put on costumes one over another (that is he may wear the uniform for the postman, over the superman costume). Before each party he can take off some of the costumes, or wear a new one. That is, if he is wearing the Postman uniform over the Superman costume, and wants to go to a party in Superman costume, he can take off the Postman uniform, or he can wear a new Superman uniform. But, keep in mind that, Gappu doesn't like to wear dresses without cleaning them first, so, after taking off the Postman uniform, he cannot use that again in the Halloween night, if he needs the Postman costume again, he will have to use a new one. He can take off any number of costumes, and if he takes off k of the costumes, that will be the last kones (e.g. if he wears costume A before costume B, to take off A, first he has to remove B).

Given the parties and the costumes, find the minimum number of costumes Gappu will need in the Halloween night.

Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case starts with a line containing an integer N(1 ≤ N ≤ 100) denoting the number of parties. Next line contains N integers, where the ith integerci(1 ≤ ci ≤ 100) denotes the costume he will be wearing in party i. He will attend party 1 first, then party 2, and so on.

Output

For each case, print the case number and the minimum number of required costumes.

Sample Input

2

4

1 2 1 2

7

1 2 1 1 3 2 1

Sample Output

Case 1: 3

Case 2: 4


题目大意:

有个人去参加聚会,不同的聚会穿不同的衣服。现在他按照顺序去参加,为了保证自己能去聚会,他可以在自己身上穿多件不同的衣服。但是一旦他脱下某一件衣服,要想再穿上它时又要花钱买新的一套了。现在问他最少需要准备多少套衣服才能都参加所有的聚会。

思路:

区间DP。

令dp[i][j]表示参加i~j个聚会所要花的最少的衣服套数。所以对于第j个聚会,如果我需要新的一套衣服,就有dp[i][j]=dp[i][j-1]+1。

如果我不买新的一套衣服,那么我就要在i~j-1的聚会里面找到这套衣服,然后把k~j-1的衣服全部脱掉,此时就有dp[i][j]=min(dp[i][j],dp[i][k]+dp[k+1][j-1])。


代码:

#include<stdio.h>
#include<string.h>
int min(int a,int b)
{
    return a<b?a:b;
}
int main()
{
    int T,n,c[105],i,j,k,dp[105][105],icase=0;
    scanf("%d",&T);
    while(T--)
    {
        icase++;
        scanf("%d",&n);
        for(i=1;i<=n;i++)
            scanf("%d",&c[i]);
        for(i=0;i<105;i++)
            for(j=0;j<105;j++)
            {dp[i][j]=99999999;
          if(i>j)dp[i][j]=0;   //初始化很重要。对于不可能的情况要赋为0。
        } 
        dp[1][1]=1;
        int mini=99999999;
        for(k=1;k<=n;k++)     //区间长度。
        {
            for(i=1;i<=n-k+1;i++)    //起点
            {
                int zhong=i+k-1;
                for(j=i;j<zhong;j++)
                {
                    if(c[j]==c[zhong])
                        dp[i][zhong]=min(dp[i][zhong],dp[i][j]+dp[j+1][zhong-1]);
                      //  if(j==1&&zhong==3)printf("%d %d\n",dp[i][j]+dp[j+1][zhong-1],dp[2][2]);
                }
                dp[i][zhong]=min(dp[i][zhong],dp[i][zhong-1]+1);
            }
        }
        printf("Case %d: ",icase);
        printf("%d\n",dp[1][n]);
    }
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值