求二叉树的先序遍历

求二叉树的先序遍历

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

 已知一棵二叉树的中序遍历和后序遍历,求二叉树的先序遍历

输入

 输入数据有多组,第一行是一个整数t (t<1000),代表有t组测试数据。每组包括两个长度小于50 的字符串,第一个字符串表示二叉树的中序遍历序列,第二个字符串表示二叉树的后序遍历序列。 

输出

 输出二叉树的先序遍历序列

示例输入

2
dbgeafc
dgebfca
lnixu
linux

示例输出

abdegcf
xnliu

提示

 

来源

 
#include<bits/stdc++.h>
using namespace std;
typedef struct node
{
    char data;
    struct node *lchild,*rchild;
}BiTNode,*BiTree;

void pro_mid_createBiTree(BiTree &T,char *mid,char *last,int len)
{
    if(len==0)
    {
        T=NULL;
        return ;
    }
    char ch = last[len-1];
    int index = 0;
    while(mid[index]!=ch)
    {
        index++;
    }
    T=(BiTNode *)malloc(sizeof(BiTNode ));
    T->data = ch;
    pro_mid_createBiTree(T->lchild,mid,last,index);
    pro_mid_createBiTree(T->rchild,mid+index+1,last+index,len-index-1);
}
void pre_order(BiTree T)
{
    if(T)
    {
        cout<<T->data;
        pre_order(T->lchild);
        pre_order(T->rchild);
    }
}
int main()
{
    BiTree T;
    char mid[110],last[110];
    int n,len;
    while(cin>>n)
    {
        while(n--)
        {
            len =0;
            cin>>mid>>last;
            len = strlen(mid);
            pro_mid_createBiTree(T,mid,last,len);
            pre_order(T);
            cout<<endl;
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值