POJ 2342 Anniversary party(树形DP)

原题地址

Anniversary party
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7291 Accepted: 4195

Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0 

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5


树形DP,实际上就像是把入门级的数塔放在了树上。


记dp[ i ][ 0 ]为 i 不去的下属的最大活跃度和。

记dp[ i ][ 1 ]为 i 去的时候,i 及其下属的最大活跃度和。


若 j 为 i 的直接下属。

dp[ i ][ 1 ] = dp[ j ][ 0 ] //  如果 i 去了,她的直接下属 i 不能去。

dp[ i ][ 0 ] = max ( dp[ j ][ 1 ] ,dp[ j ][ 0 ] )  //如果 i 不去,那她的直接下属可以去或者不去。


我们从叶子节点开始,一直向根节点进行决策。



AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int par[6066];
bool vis[6066];
int dp[6066][3];
int n;

void init(int n)
{
    for(int i=1;i<=n;i++)
    {
        par[i]=i;//初始化i的父节点为i(我参考的并查集的写法)
        vis[i]=0;//检查i是否已经进行过决策
        dp[i][1]=0;
        dp[i][0]=0;
    }
}
void dfs(int root)
{
    vis[root]=1;
    for(int i=1;i<=n;i++)
    {
        if(!vis[i]&&par[i]==root)
        {
            dfs(i);//dfs要在前,更新DP要在后。因为我们是从叶子节点开始的。
            dp[root][1]+=dp[i][0];
            dp[root][0]+=max(dp[i][0],dp[i][1]);
        }
    }
}
int main()
{
    while(~scanf("%d",&n))
    {
        init(n);
        int a,b;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&dp[i][1]);
        }
        while(scanf("%d%d",&a,&b)&&(a||b))
        {
            par[a]=b;
        }
        int root=1;
        while(par[root]!=root)
        {
            root=par[root];
        }
        dfs(root);
        printf("%d\n",max(dp[root][1],dp[root][0]));
    }
    return 0;
}


我们从叶子节点开始。
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值