每日三题-Day4-A(HDU 1160 FatMouse's Speed 最长有序子序列)

原题地址

FatMouse's Speed

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16043 Accepted Submission(s): 7067
Special Judge

Problem Description
FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.

Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed.

Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that

W[m[1]] < W[m[2]] < ... < W[m[n]]

and

S[m[1]] > S[m[2]] > ... > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.

Sample Input
  
  
6008 1300 6000 2100 500 2000 1000 4000 1100 3000 6000 2000 8000 1400 6000 1200 2000 1900

Sample Output
  
  
4 4 5 9 7

题意:

给你多个老鼠的体重和速度,求一个最长的序列,使得老鼠的体重递增而速度递减。


思路:

就是一个最长有序子序列问题,与HDU 1069类似,而且更加简单。

HDU1069题解:http://blog.csdn.net/lulu11235813/article/details/70244506


用结构体储存老鼠的编号,体重,速度,前驱老鼠,长度。

长度指的是以这只老鼠为最后一只的序列的最长长度。


AC代码

#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;

struct Mouse
{
    int id;
    int speed;
    int weight;
    int pre;
    int dp;
} mouse[10010];

int cmp(Mouse a,Mouse b)
{
    if(a.weight==b.weight)
    {
        return a.speed>b.speed;
    }
    return a.weight<b.weight;
}
int dfs(int p)
{
    //printf("@%d %d\n",p,mouse[p].pre);
    if(p==-1) return 0;
    dfs(mouse[p].pre);
    printf("%d\n",mouse[p].id);
    return 0;
}
int main()
{
    int i=0;
    while(~scanf("%d%d",&mouse[i].weight,&mouse[i].speed))
    {
        mouse[i].id=i+1;
        mouse[i].pre=-1;
        mouse[i].dp=1;
        i++;
    }
    sort(mouse,mouse+i,cmp);
    int n=i;
    mouse[0].dp=1;
    int ans=1;
    int p=0;
    for(int i=1; i<n; i++)
    {
        for(int j=0; j<i; j++)
        {
            if(mouse[i].weight>mouse[j].weight&&mouse[i].speed<mouse[j].speed)
            {
                if(mouse[j].dp+1>mouse[i].dp)
                {
                    mouse[i].dp=mouse[j].dp+1;
                    mouse[i].pre=j;
                }
            }
        }
        if(mouse[i].dp>ans)
        {
            ans=mouse[i].dp;
            p=i;
        }
    }
    /*
    for(int i=0;i<n;i++)
    {
        printf("id:%d w:%d s:%d pre:%d dp:%d\n",mouse[i].id,mouse[i].weight,mouse[i].speed,mouse[i].pre,mouse[i].dp);
    }*/
    printf("%d\n",ans);
    dfs(p);
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值