hdu 5373 - The shortest problem 解题报告

The shortest problem

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1141    Accepted Submission(s): 554


Problem Description
In this problem, we should solve an interesting game. At first, we have an integer n, then we begin to make some funny change. We sum up every digit of the n, then insert it to the tail of the number n, then let the new number be the interesting number n. repeat it for t times. When n=123 and t=3 then we can get 123->1236->123612->12361215.
 

Input
Multiple input.
We have two integer n (0<=n<= 104  ) , t(0<=t<= 105 ) in each row.
When n==-1 and t==-1 mean the end of input.
 

Output
For each input , if the final number are divisible by 11, output “Yes”, else output ”No”. without quote.
 

Sample Input
  
  
35 2 35 1 -1 -1
 

Sample Output
  
  
Case #1: Yes Case #2: No
 

题意:给你n,t。例1:n=35,t=2。第一次3+5=8,变为358,第二次,3+5+8=16,变为35816.发现35816可以被11整除。输出yes。

题解:这里最重要的是要知道怎么样的数可以被十一整除,可以通过百度或学习数论的知识了解到:

    当一个数的奇数位之和与偶数位之和的差的绝对值能被11整除,那么该数就可以被11整除。如35816,奇数位之和为17,偶数位之和是6,差的绝对值为11,所以能被11整除。

参考代码:

#include<stdio.h>
#include<stdlib.h>
#define ll __int64
int s[30],k;
ll luwherehandsome(ll x)
{
	int tem=0;
	while(x)
	{
		s[k++]=x%10;
		tem+=x%10;
		x/=10;
	}
	return tem;
}
int main()
{
	int n,t,v,q=0;
	ll tem,ans,m;
	while(~scanf("%d%d",&n,&t))
	{
		ans=0;
		q++;
		if(n==-1&&t==-1)
		    break;
        k=0;
        v=1;
        m=luwherehandsome(n);
        while(k--)
        {
        	if(v)
        	{
        	    ans+=s[k];
        	    v=0;
        	}
   	        else
   	        {
   	            ans-=s[k];
   	            v=1;
   	        }
        }
        while(t--)
        {
        	k=0;
        	m+=luwherehandsome(m);
        	while(k--)
            {
        	    if(v)
        	    {
        	        ans+=s[k];
        	        v=0;
        	    }
   	            else
   	            {
   	                ans-=s[k];
   	                v=1;
   	            }
            }
        }
        printf("Case #%d: ",q);  
        if(abs(ans)%11)  
            printf("No\n");  
        else  
            printf("Yes\n");  
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值