HDU Play on Words(并查集——欧拉通路)

 Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us.

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ``acm'' can be followed by the word ``motorola''. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door.

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters ‘a’ through ‘z’ will appear in the word. The same word may appear several times in the list.
Output
Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times.
If there exists such an ordering of plates, your program should print the sentence “Ordering is possible.”. Otherwise, output the sentence “The door cannot be opened.”.
Sample Input

3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok

Sample Output

The door cannot be opened.
Ordering is possible.
The door cannot be opened.

题意:一个门上有若干模块, 每个模块上有一个单词, 如果可以将所有单词按照第一个单词的尾字母就是第二个单词的首字母串联起来, 门就可以被打开, 否则不能被打开。

这个题抽象的考察了欧拉路的问题, 仔细想想不难知道, 此题是一个欧拉通路问题, 使用了并查集。

欧拉通路:所有入度等于出度或只有两个的入度不等于出度且入度与出度的差一组为一另一组为负一。

代码如下:

#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=26+5;
int fa[maxn];
int in[maxn],out[maxn];
int m;
int findset(int u)
{
    if(fa[u] == -1)return u;
    return fa[u]=findset(fa[u]);
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        memset(in,0,sizeof(in));
        memset(out,0,sizeof(out));
        memset(fa,-1,sizeof(fa));
        scanf("%d",&m);
        for(int i=0;i<m;i++)
        {
            char str[1200];
            scanf("%s",str);
            int len=strlen(str);
            int u=str[0]-'a',v=str[len - 1] - 'a';
            in[u]++;
            out[v]++;
            u=findset(u),v=findset(v);
            if(u != v)fa[u]=v;
        }
        int cnt=0;
        for(int i=0;i<26;i++)
            if((in[i]||out[i])&&findset(i)==i)cnt++;
        if(cnt>1)
        {
            printf("The door cannot be opened.\n");
            continue;
        }
        int c1=0, c2=0, c3=0;
        for(int i=0;i<26;i++)
        {
            if(in[i]==out[i]) continue;
            else if(in[i]-out[i]==1) c1++;
            else if(out[i]-in[i]==1) c2++;
            else c3++;
        }
        if( ( (c1==c2&&c1==1)||(c1==c2&&c1==0) )&&c3==0)
            printf("Ordering is possible.\n");
        else
            printf("The door cannot be opened.\n");
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值