Sorting It All Out (拓扑排序)

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three:

Sorted sequence determined after xxx relations: yyy...y.
Sorted sequence cannot be determined.
Inconsistency found after xxx relations.

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence.

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

给定从A开始的n个字母, m个条件, 判断是否可以通过给定的条件确定序列。可以确定时输出在第几个条件可以确定, 不能确定输出Sorted sequence cannot be determined., 存在矛盾输出在第几个条件出现矛盾。

输入一次就进行一次拓扑排序当可以确定序列顺序或者出现矛盾时就不再处理。

#include<stdio.h>
#include<string.h>
int mp[40][40];
int in[40],q[40];

int tp_sort(int n)
{
    int cid=0;
    int nowin[40];
    int loc,cnt,flag=1;

    memcpy(nowin,in,sizeof(in));

    for(int i = 1;i <= n;++i)
    {
        cnt = 0;

        for(int j = 1;j <= n;++j)
            if(nowin[j]==0){ ++cnt; loc = j;}

        if(cnt == 0) return 0;
        if(cnt > 1) flag = -1;

        q[cid++] = loc;   //入度为零的点入队
        nowin[loc]--;
        for(int j = 1;j <= n;++j)
            if(mp[loc][j] == 1) nowin[j]--;
    }
    return flag;
}

int main()
{
    int m,n,sign;
    char op[5];
    while(scanf("%d%d",&n,&m),n+m)
    {
        memset(mp,0,sizeof(mp));
        memset(in,0,sizeof(in));

        sign=0;

        for(int i = 1;i <= m;i++)
        {
            scanf("%s",op);

            if(sign) continue;

            int x = op[0]-'A'+1;
            int y = op[2]-'A'+1;

            mp[x][y]=1;

            in[y]++;

            int tmp=tp_sort(n);

            if(tmp == 0)
            {
                printf("Inconsistency found after %d relations.\n",i);
                sign=1;
            }
            if(tmp == 1)
            {
                printf("Sorted sequence determined after %d relations: ",i);
                for(int j=0;j<n;j++)
                    printf("%c",q[j]+'A'-1);
                printf(".\n");
                sign=1;
            }
        }
        if(!sign)
            printf("Sorted sequence cannot be determined.\n");
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值