背包

Problem Description

Many years ago , in Teddy’s hometownthere was a man who was called “Bone Collector”. This man like to collectvaries of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip ofcollecting there are a lot of bones , obviously , different bone has differentvalue and different volume, now given the each bone’s value along his trip ,can you calculate out the maximum of the total value the bone collector can get?


Input

The first line contain a integer T ,the number of cases.
Followed by T cases , each case three lines , the first line contain twointeger N , V, (N <= 1000 , V <= 1000 )representing the number of bonesand the volume of his bag. And the second line contain N integers representingthe value of each bone. The third line contain N integers representing thevolume of each bone.

Output

One integer per line representingthe maximum of the total value (this number will be less than 231).

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output

14

 

01背包模板题,主要要写出状态转移方程,和递推差不多,求出当前物品的最大值就是要比较下一件物品是放还是不放,将放进去之后的大值存入数组中,之后从数组中查找,就是使用记忆化数组,这样的复杂度会缩小为O(NV)

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int t,n,v,va[1010],vi[1010],dp[1010][1010];
void solve()
{
	memset(dp,0,sizeof(dp));
	int i,j;
	for(i=n-1;i>=0;i--)
	{
		for(j=0;j<=v;j++)
		{
			if(j<vi[i])
				dp[i][j]=dp[i+1][j];
			else
				dp[i][j]=max(dp[i+1][j],dp[i+1][j-vi[i]]+va[i]);	
		}
	}
//	for(i=n-1;i>=0;i--)
//	{
//		for(j=0;j<=v;j++)
//		{
//			printf("%3d ",dp[i][j]);
//		}
//		printf("\n");
//	 } 
	printf("%d\n",dp[0][v]);
}
int main()
{
	int i;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&v);
		for(i=0;i<n;i++)
			scanf("%d",&va[i]);
		for(i=0;i<n;i++)
			scanf("%d",&vi[i]);
		solve();
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值