Doing Homework

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
InputThe input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. 
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject's name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject's homework). 

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier. 
OutputFor each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one. 
Sample Input
2
3
Computer 3 3
English 20 1
Math 3 2
3
Computer 3 3
English 6 3
Math 6 3
Sample Output
2
Computer
Math
English
3
Computer
English
Math


        
  
Hint
In the second test case, both Computer->English->Math and Computer->Math->English leads to reduce 3 points, but the 
word "English" appears earlier than the word "Math", so we choose the first order. That is so-called alphabet order.

        
 


题目n只有16,进行状态压缩,用1~(1<<n)表示所有的状态,然后枚举(1<<j);当两个数的&为1,就说明在本轮j时间可能发生,然后取前一个状态为i-(1<<j),计算分数,看是否需要更新,然后将一系列需要更新的值用状态转移方程更新dp[i].parent = pre;dp[i].score = score + dp[pre].score; dp[i].id = j;  dp[i].time = dp[pre].time + node[j].cost;最后采用递归的方法输出答案

代码如下:

#include<stdio.h>
#include<iostream>
using namespace std;
const int M = 1e9 + 100;
struct Node
{
    string name;
    int cost;
    int dead;
}node[20];
struct Ans
{
    int time, parent, id, score;
}dp[1<<16];
int main()
{
    int T;
    cin >> T;
    while(T--)
    {
        int n;
        cin >> n;
        for(int i = 0; i < n; i ++)
        {
            cin >> node[i].name >> node[i].dead >> node[i].cost;
        }
        for(int i = 1; i < (1<<n); i ++)
        {
            dp[i].score = M;
            for(int j = 0; j < n; j ++)
            {
                if(i & (1<<j))
                {
                    int pre = i-(1<<j);
                    int score = dp[pre].time + (node[j].cost - node[j].dead);
                    if(score < 0) score = 0;
                    if(score+dp[pre].score <= dp[i].score)
                    {
                        dp[i].parent = pre;
                        dp[i].score = score + dp[pre].score;
                        dp[i].id = j;
                        dp[i].time = dp[pre].time + node[j].cost;
                    }
                }
            }
        }
        cout << dp[(1<<n)-1].score <<endl;
        int ans[20], num = 0, cnt = (1<<n)-1;
        while(cnt)
        {
            ans[num++] = dp[cnt].id;
            cnt = dp[cnt].parent;
        }
        //ans[num++] = cnt;
        for(int i = num-1; i >= 0; i --)
        {
            cout<< node[ans[i]].name <<endl;
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值