Party All the Time HDU - 4355 三分

Description

In the Dark forest, there is a Fairy kingdom where all the spirits will go together and Celebrate the harvest every year. But there is one thing you may not know that they hate walking so much that they would prefer to stay at home if they need to walk a long way.According to our observation,a spirit weighing W will increase its unhappyness for S 3*W units if it walks a distance of S kilometers.
Now give you every spirit’s weight and location,find the best place to celebrate the harvest which make the sum of unhappyness of every spirit the least.

Input

The first line of the input is the number T(T<=20), which is the number of cases followed. The first line of each case consists of one integer N(1<=N<=50000), indicating the number of spirits. Then comes N lines in the order that x ii<=x i+1i+1 for all i(1<=i

Output

For each test case, please output a line which is “Case #X: Y”, X means the number of the test case and Y means the minimum sum of unhappyness which is rounded to the nearest integer.

Sample Input

1
4
0.6 5
3.9 10
5.1 7
8.4 10

Sample Output

Case #1: 832

Hint

题意

给n个位置 要求找到一个位置 其他每个位置到这里的距离s 要求

s3w[i]
最小

题解:

就是求这个函数的最小值
利用三分搜索来枚举结果位置 如果ll这个位置的值大于rr 则要以ll作为l 而较小的rr则先不动 这样不断逼近极值

AC代码

#include <cstdio>
#include <iostream>
#include <queue>
#include <map>
#include <cmath>
#include <cstring>
#include <algorithm>
using namespace std;
typedef long long LL;
const int N = 5e4+5;
const double eps = 1e-4;
double a[N];
double w[N];
int n;
double f(double x){
    double ans = 0,s;
    for (int i = 0; i < n; ++i){
        s = fabs(x-a[i]);
        ans += s*s*s*w[i];
    }
    return ans;
}
double ternay(double l,double r){
    while (r-l>eps){
        double ll = (2*l+r)/3;
        double rr = (2*r+l)/3;
        double ans1 = f(ll);
        double ans2 = f(rr);
        if (ans1>ans2){
            l = ll;
        }
        else r = rr;
    }
    return l;
}
int main(){
    int t;
    scanf("%d",&t);
    int kase = 1;
    while (t--){
        scanf("%d",&n);
        double r = -1e6,l = 1e6;
        for (int i = 0; i < n; ++i){
            scanf("%lf%lf",&a[i],&w[i]);
            if (a[i]>r) r = a[i];
            if (a[i]<l) l = a[i];
        }

        double ar = ternay(l,r);
        printf("Case #%d: ",kase++);
        printf("%.0lf\n",f(ar));
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值