HDU-5533 Dancing Stars on Me(几何/极点排序)

Dancing Stars on Me

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 262144/262144K (Java/Other)
Total Submission(s) : 34   Accepted Submission(s) : 23
Problem Description
The sky was brushed clean by the wind and the stars were cold in a black sky. What a wonderful night. You observed that, sometimes the stars can form a regular polygon in the sky if we connect them properly. You want to record these moments by your smart camera. Of course, you cannot stay awake all night for capturing. So you decide to write a program running on the smart camera to check whether the stars can form a regular polygon and capture these moments automatically.

Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon. To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.
 

Input
The first line contains a integer $T$ indicating the total number of test cases. Each test case begins with an integer $n$, denoting the number of stars in the sky. Following $n$ lines, each contains $2$ integers $x_i, y_i$, describe the coordinates of $n$ stars. $1 \le T \le 300$ $3 \le n \le 100$ $-10000 \le x_i, y_i \le 10000$ All coordinates are distinct.
 

Output
For each test case, please output "`YES`" if the stars can form a regular polygon. Otherwise, output "`NO`" (both without quotes).
 

Sample Input
  
  
3 3 0 0 1 1 1 0 4 0 0 0 1 1 0 1 1 5 0 0 0 1 0 2 2 2 2 0
 

Sample Output
  
  
NO YES NO
 

Source
2015ACM/ICPC亚洲区长春站-重现赛(感谢东北师大)

传送门:http://acm.hdu.edu.cn/webcontest/contest_showproblem.php?pid=1001&ojid=0&cid=11108&hide=0

题意:判断这n个点组成的图形是否为等边凸n边形

题解:直接上模板


#include<cstdio>
#include<algorithm>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#define FIN freopen("in.txt","r",stdin)
#define eps 1e-9
using namespace std;
const int maxn = 105;
int sgn(double x){
    if(fabs(x)<eps) return 0;
    if(x<0) return -1;
    else return 1;
}
struct Point{
    double x,y;
    Point(double xx,double yy){x=xx;y=yy;}
    Point(){}
    Point operator-(const Point& p)const{
        return Point(x-p.x,y-p.y);
    }
    double operator^(const Point& p)const{
        return x*p.y-y*p.x;
    }
    double operator*(const Point& p)const{
        return x*p.x+y*p.y;
    }
}p[maxn];
double dist(Point p1,Point p2){
    return sqrt((p1-p2)*(p1-p2));
}
bool cmp(Point p1,Point p2){
    double tmp=(p1-p[0])^(p2-p[0]);
    if(sgn(tmp)>0) return true;
    if(sgn(tmp)==0&&sgn(dist(p1,p[0])-dist(p2,p[0]))>=0) return true;
    return false;
}
bool ok(Point p1,Point p2,Point p3){
    double tmp=(p1-p2)^(p1-p3);
    if(sgn(tmp)<=0||dist(p1,p2)!=dist(p2,p3)) return false;
    return true;
}
int main(){
    int T,n;
   // FIN;
    scanf("%d",&T);
    while(T--){
        scanf("%d",&n);
        int k=0;
        for(int i=0;i<n;i++){
            scanf("%lf%lf",&p[i].x,&p[i].y);
            if((p[k].y>p[i].y)||(p[k].y==p[i].y&&p[k].x>p[i].x)) k=i;
        }
        swap(p[k],p[0]);
        sort(p+1,p+n,cmp);
        bool flag=1;
        for(int i=0;i<n;i++){
          //  printf("%.f %.f\n",p[i].x,p[i].y);
            if(!ok(p[i],p[(i+1)%n],p[(i+2)%n])) {
                flag=0;
                break;
            }
        }
        if(flag) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值