ZOJ 3872-Beauty of Array(递推||DP)

5 篇文章 0 订阅
Beauty of Array

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Edward has an array A with N integers. He defines the beauty of an array as the summation of all distinct integers in the array. Now Edward wants to know the summation of the beauty of all contiguous subarray of the arrayA.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 100000), which indicates the size of the array. The next line containsN positive integers separated by spaces. Every integer is no larger than 1000000.

Output

For each case, print the answer in one line.

Sample Input
3
5
1 2 3 4 5
3
2 3 3
4
2 3 3 2
Sample Output
105
21
38

Author: LIN, Xi

Source: The 12th Zhejiang Provincial Collegiate Programming Contest


题目意思:

给一些数字,可以看成一个集合,求它们所有的连续且不重复子集的和。

例如:1 2 3

(1+2+3)+(1+2)+(2+3)+(1)+(2)+(3)=20。

例如:1 2 3 2

(1+2+3+2)(1+2+3)+(1+2+3)+(2+3+2)+(2+3)+(1+2)+(2+3)+(3+2)+(1)+(2)+(3)+(2)=38。

要去掉重复的数字再进行计算。

解题思路(←这儿有个传送门):

①如果没有重复数字

  举例如上。

可以得出,没有重复的长度为n的数组,如果在第n+1个位置,再增加一个不重复的数x,则与没有重复的长度为n的数组的总beauty要增加x*(n+1)

②如果有重复数字

举例如上。

在1 2 3 2到第四个数,即2时,新增的序列为1,2,3,2   ,   2,3,2,  3,2,  2,但是和前一个3相比,以这个2为结尾的序列总beauty值增加了2*2,因为这个2与上一个2距离为2。


/* 
* Copyright (c) 2016, 烟台大学计算机与控制工程学院 
* All rights reserved. 
* 文件名称:dp.cpp 
* 作    者:单昕昕 
* 完成日期:2016年4月5日 
* 版 本 号:v1.0 
*/  
#include<iostream>
#include<cstring>
using namespace std;
long long  val[100005],pos[100005];
//不能用int 不然就WA了!!
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n,a,i;
        long long ans=0;//这里也是,要用long long
        cin>>n;
        memset(val,0,sizeof(val));
        memset(pos,0,sizeof(pos));
        for(i=1; i<=n; ++i)
        {
            cin>>a;
            val[i]=val[i-1]+(i-pos[a])*a;//当前串的值
            pos[a]=i;//记录a的位置i
            ans+=val[i];//更新
        }
        cout<<ans<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值