HDU 2844-Coins(多重背包)

34 篇文章 0 订阅

Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11770    Accepted Submission(s): 4686


Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
 

Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
 

Output
For each test case output the answer on a single line.
 

Sample Input
  
  
3 10 1 2 4 2 1 1 2 5 1 4 2 1 0 0
 

Sample Output
  
  
8 4
 

Source
 

Recommend
gaojie   |   We have carefully selected several similar problems for you:   1203  1171  1864  2845  2191

题目意思:

有一些硬币的面值和这些面值的硬币的个数,求这些硬币能组成不超过价值m的面值有多少种可能?

解题思路:

多重背包。
可以分成两部分考虑:
①如果面值和数量总值大于m,可以看成完全背包来处理;
②否则,分解成01背包,增加一个k表示取的硬币数量。
dp[i]数组表示取硬币,所组成的价值为i。


#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
using namespace std;
#define MAX 100000
int dp[MAX];
int c[MAX],w[MAX];
int n,m;

void ZeroOnePack(int cost,int wei)//01背包
{
    int i;
    for(i = m; i>=cost; i--)
        dp[i]=max(dp[i],dp[i-cost]+wei);
}

void CompletePack(int cost,int wei)//完全背包
{
    int i;
    for(i = cost; i<=m; i++)
        dp[i] = max(dp[i],dp[i-cost]+wei);
}

void MultiplePack(int cost,int wei,int cnt)//多重背包
{
    if(m<=cnt*cost)//完全背包
    {
        CompletePack(cost,wei);
        return ;
    }
    else
    {
        int k;
        for(k=1; k<=cnt; ++k)
        {
            ZeroOnePack(k*cost,k*wei);//01背包
            cnt=cnt-k;
        }
        ZeroOnePack(cnt*cost,cnt*wei);//01背包
    }
}

int main()
{
    while(~scanf("%d%d",&n,&m),n+m)
    {
        int i;
        for(i = 0; i<n; i++)
            scanf("%d",&c[i]);
        for(i = 0; i<n; i++)
            scanf("%d",&w[i]);
        memset(dp,0,sizeof(dp));
        for(i=0; i<n; i++)
            MultiplePack(c[i],c[i],w[i]);
        int ans=0;
        for(i=1; i<=m; i++)
            if(dp[i]==i)
                ++ans;
        printf("%d\n",ans);
    }
    return 0;
}

写在主函数里面就TLE了……就像这样↓

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
using namespace std;
#define MAXN 105
int a[MAXN],c[MAXN];
int dp[MAXN];
//dp[i]:价值为i的物品
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m),n+m)
    {
        memset(dp,0,sizeof(dp));
        memset(a,0,sizeof(a));
        memset(c,0,sizeof(c));
        int i,j,k,ans=0;
        for(i=0; i<n; ++i)
            scanf("%d",&a[i]); //value
        for(i=0; i<n; ++i)
            scanf("%d",&c[i]); //number
        for(i=0; i<n; ++i)
        {
            if(a[i]*c[i]>=m)//完全背包
                for(j=a[i]; j<=m; j++)
                    dp[j]=max(dp[j],dp[j-a[i]]+a[i]);
            else//01背包
            {
                for(k=1; k<=c[i]; k<<=1) //数量
                {
                    for(j=m; j>=k*a[i]; --j)//价值
                        dp[j]=max(dp[j],dp[j-k*a[i]]+k*a[i]);
                    c[i]-=k;//减去用过的数量
                }
                for(j=m; j>=a[i]*c[i]; --j)
                    dp[j]=max(dp[j],dp[j-a[i]*c[i]]+a[i]*c[i]);
            }
        }
        for(i=1; i<=m; ++i)
            if(dp[i]==i) ++ans;
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值