hdu-2844-Coins (多重背包+二进制优化)

Coins

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 9 Accepted Submission(s) : 5
Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.

Input

The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4

题意:tony 想要买一个手表 他后n个硬币面值为 v[i],每种硬币的数量为 num[i],要买一个价值不超过 m的东西 (价钱小于等于m即可),
输入:一个 n 和一个 m 以 0 0结束;第二行是 2n个数 分别是 v[i]和num[i].
输出:1-m之间有多少种价格tony 可以支付。

思路: 多重背包,在dp初始赋值是 负成 负数 作为标记即可。

code

#include<cstdio>
#include<iostream>
#include<cstring>
#define inf 0x3f3f3f3f
using namespace std;
int dp[101000],v[110],num[110];
int n,m;
//m背包的总容量、v物品的体积、w物品的价值
void OneZeroPack(int m,int v,int w)  //0-1背包
{
    for(int i=m;i>=v;i--)
        dp[i]=max(dp[i],dp[i-v]+w);
}

//m背包的总容量、v物品的体积、w物品的价值
void CompletePack(int m,int v,int w)  //完全背包
{
    for(int i=v;i<=m;i++)
        dp[i]=max(dp[i],dp[i-v]+w);
}

//m背包的总容量、v物品的体积、w物品的价值、num物品的数量
void MultiplePack(int m,int v,int w,int num)//多重背包
{
    if(v*num>=m)
    {
        CompletePack(m,v,w);
        return ;
    }
    int k=1;
    for(k=1;k<=num;k<<=1)
    {
        OneZeroPack(m,k*v,k*w);
        num=num-k;
    }
    if(num)
        OneZeroPack(m,num*v,num*w);
}
int main()
{
    while(scanf("%d%d",&n,&m),n||m){
        for(int i=0;i<n;i++)
            scanf("%d",&v[i]);
        for(int i=0;i<n;i++)
            scanf("%d",&num[i]);
        for(int i=0;i<=m;i++)
            dp[i]=-inf;
        dp[0]=0;
        for(int i=0;i<n;i++){
            MultiplePack(m,v[i],v[i],num[i]);
        }
        int ans=0;
        for(int i=1;i<=m;i++)
            if(dp[i]>0) ans++;
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值