Knight Moves
Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 26034 | Accepted: 12276 |
Description
Background
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him?
The Problem
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov.
For people not familiar with chess, the possible knight moves are shown in Figure 1.
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him?
The Problem
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov.
For people not familiar with chess, the possible knight moves are shown in Figure 1.
Input
The input begins with the number n of scenarios on a single line by itself.
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, ..., l-1}*{0, ..., l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, ..., l-1}*{0, ..., l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.
Output
For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.
Sample Input
3 8 0 0 7 0 100 0 0 30 50 10 1 1 1 1
Sample Output
5 28 0
Source
TUD Programming Contest 2001, Darmstadt, Germany
题目意思:
给定棋盘的大小N和起终点两个位置的坐标,计算马从起点到终点所需的最小步骤。
解题思路:
跳马的问题做了不少,比如POJ 2243,和这题特别像。
以前都是DFS水过去的,结果这个T了,┑( ̄Д  ̄)┍手写了个BFS才又水过去……
#include <iostream>
#include <cstdio>
#include <cstring>
#include <bitset>
#include <queue>
#include <iomanip>
#include <algorithm>
#define MAXN 333
#define INF 0xfffffff
using namespace std;
bool vis[MAXN][MAXN];
int step[MAXN][MAXN];
int dir[8][2]= {{-2,-1},{-2,1},{-1,-2},{-1,2},{2,-1},{2,1},{1,-2},{1,2}};
int res=0,st,ans;
int sx,sy,ex,ey;
int n;
struct node
{
int x,y;
};
queue<node> q;
void bfs(int x,int y)
{
node t;
t.x=x,t.y=y;
q.push(t);
while(!q.empty())
{
t=q.front();
q.pop();
if(t.x==ex&&t.y==ey)
{
ans=step[t.x][t.y];
return ;
}
for(int i=0; i<8; ++i)
{
node te;
te.x=t.x+dir[i][0];
te.y=t.y+dir[i][1];
if(te.x<0||te.y<0||te.x>=n||te.y>=n||st>=ans) continue;
{
if(!vis[te.x][te.y])
{
vis[te.x][te.y]=true;
step[te.x][te.y]=step[t.x][t.y]+1;
q.push(te);
}
}
}
}
}
int main()
{
#ifdef ONLINE_JUDGE
#else
freopen("G:/cbx/read.txt","r",stdin);
//freopen("G:/cbx/out.txt","w",stdout);
#endif
/*ios::sync_with_stdio(false);
cin.tie(0);*/
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
scanf("%d%d%d%d",&sx,&sy,&ex,&ey);
memset(vis,false,sizeof(vis));
memset(step,0,sizeof(step));
while(!q.empty()) q.pop();
st=0;
ans=MAXN;
bfs(sx,sy);
printf("%d\n",ans);
}
return 0;
}