poj1703——Find them, Catch them【分类并查集】

Find them, Catch them
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 49988 Accepted: 15349

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.

In the same gang.

题意:有两种犯人,让你判断这两种犯人属于哪一种,当输入A值表示判断犯人是不是属于同一种类,如果是则输出

In the same gang.如果不是则输出In different gangs.如果无法确定则输出Not sure yet.

这道题和挑战程序设计竞赛上的那道食物链的属于同类题型,并查集是一种维护同一种数据的数据结构,而这种题则是通过

并查集区分不同种类,就可以用并查集合并不同种类为一类在判断,详情见代码

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;  
const int maxn = 1e5 + 5;  
int n, m;  
int pre[maxn*2];   
void init(int n){
	for(int i=1;i<=n;i++){
		pre[i]=i;
	}
}
int find(int x){
	int r=x;
	while(pre[r]!=r) r=pre[r];
	int i=x,j;
	while(i!=r){
		j=pre[i];
		pre[i]=r;
		i=j;
	}
	return r;
}
void join(int x,int y){
	int fx=find(x),fy=find(y);
	if(fx!=fy) pre[fx]=fy;
}
bool same(int x,int y){
	return find(x)==find(y);
}
int main(){
	//char c;
	int t;
	scanf("%d\n",&t);
	while(t--){
		scanf("%d %d\n",&n,&m);
		init(2*n);
		int p,q;
		char c;
		while(m--){
			cin>>c;
			if(c=='D'){
				scanf("%d %d",&p,&q);
				join(p,q+n);//分别归于两个种类 
				join(p+n,q);
			}
			else{
				scanf("%d%d",&p,&q);
				if(same(p,q+n)||same(p+n,q)) printf("In different gangs.\n");  //依次判断
				else if(same(p,q)||same(p+n,q+n)) printf("In the same gang.\n");  
				else  printf("Not sure yet.\n");  
			}
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值