1002. A+B for Polynomials (25)
This time, you are supposed to find A+B where A and B are two polynomials.
Input
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.
Output
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input2 1 2.4 0 3.2 2 2 1.5 1 0.5Sample Output
3 2 1.5 1 2.9 0 3.2
K是多项式非零项的个数,分别给出两个多项式的指数N和系数aN,计算两个多项式的值。
注意最后可能计算结果为全〇,要保留一位小数,零项不输出且输出式末尾不含空格。
#include<bits/stdc++.h>
using namespace std;
#define MAXN 1010
#define INF 0xfffffff
int main()
{
#ifdef ONLINE_JUDGE
#else
freopen("F:/cb/read.txt","r",stdin);
//freopen("F:/cb/out.txt","w",stdout);
#endif
ios::sync_with_stdio(false);
cin.tie(0);
double a[MAXN],b[MAXN],ans[MAXN];
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
memset(ans,0,sizeof(ans));
int k,ma=-1,mb=-1,m=-1,mm=-1,cnt=0,mi=INF;
cin>>k;
while(k--)
{
int x;
double y;
cin>>x>>y;
ma=max(ma,x);
a[x]=y;
}
cin>>k;
while(k--)
{
int x;
double y;
cin>>x>>y;
mb=max(mb,x);
b[x]=y;
}
m=max(ma,mb);
for(int i=m; i>=0; --i)
{
if(a[i]==0&&b[i]==0) continue;
if(a[i]+b[i]!=0)
{
++cnt;
mm=max(mm,i);
mi=min(mi,i);
ans[i]=a[i]+b[i];
}
}
cout<<cnt;
if(cnt>0)
{
cout<<" ";
for(int i=m; i>mi; --i)
if(ans[i]!=0)
cout<<i<<" "<<setiosflags(ios::fixed)<<setprecision(1)<<ans[i]<<" ";
cout<<mi<<" "<<setiosflags(ios::fixed)<<setprecision(1)<<ans[mi]<<endl;
}
return 0;
}