1204#POJ3627 Bookshelf ,POJ3663 Costume Party

摘要
-两个普通的题目 Bookshelf 求给定一组数中至少选择几个数的和可以不小于给定的另一个数B;Costume Party中求给定一组数中选择两个数,他们的和不大于给定数S,求有多少对这样的数
原题目摘要
Bookshelf 
http://poj.org/problem?id=3627 

Description

Farmer John recently bought a bookshelf for cow library, but the shelf is getting filled up quite quickly, and now the only available space is at the top.

Each of the N cows (1 ≤ N ≤ 20,000) has some height of Hi (1 ≤Hi ≤ 10,000) and a total height summed across all N cows ofS. The bookshelf has a height of B (1 ≤ BS < 2,000,000,007).

To reach the top of the bookshelf taller than the tallest cow, one or more of the cows can stand on top of each other in a stack, so that their total height is the sum of each of their individual heights. This total height must be no less than the height of the bookshelf. Since more cows than necessary in the stack can be dangerous, your job is to find the set of cows that produces a stack of the smallest number of cows possible such that the stack can reach the bookshelf.

Input

* Line 1: Two space-separated integers: N and B
* Lines 2..N+1: Line i+1 contains a single integer: Hi

Output

* Line 1: A single integer representing the size of the smallest set of cows that can reach the bookshelf.

Sample Input
6 40
6
18
11
13
19
11

Sample Output
3

Costume Party

Description

It's Halloween! Farmer John is taking the cows to a costume party, but unfortunately he only has one costume. The costume fits precisely two cows with a length ofS (1 ≤ S ≤ 1,000,000). FJ has N cows (2 ≤ N ≤ 20,000) conveniently numbered 1..N; cowi has length Li (1 ≤ Li ≤ 1,000,000). Two cows can fit into the costume if the sum of their lengths is no greater than the length of the costume. FJ wants to know how many pairs of two distinct cows will fit into the costume.

Input

* Line 1: Two space-separated integers: N and S
* Lines 2..N+1: Line i+1 contains a single integer: Li

Output

* Line 1: A single integer representing the number of pairs of cows FJ can choose. Note that the order of the two cows does not matter.

Sample Input
4 6
3
5
2
1
Sample Output
4

题目理解
-两个题目 好像是同系列的,首先排一下序,问题基本就解决了
注意
-我觉得 现在读听闻题目都有点困难,时间都在翻译上了gg
日期
-2017 12 4
附加
-
代码
- Bookshelf
#include <algorithm>
#include <cstdio>
#include <iostream>
#define MAX 20005
using namespace std;

int H[MAX];
int n,B,stk;

int main(){
    scanf("%d%d",&n,&B);
    for(int i=0;i<n;i++){
        scanf("%d",&H[i]);
    }
    sort(H,H+n);
    stk=0;
    for(int i=n-1;i>=0;i--){
        stk+=H[i];
        if(stk>=B){
            printf("%d",n-i);
            break;
        }
    }
    return 0;
}

- Costume Party

#include <algorithm>
#include <cstdio>
#include <iostream>
#define MAX 20005
using namespace std;

int L[MAX];
int n,S;

int main(){
    scanf("%d%d",&n,&S);
    for(int i=0;i<n;i++){
        scanf("%d",&L[i]);
    }
    sort(L,L+n);
    int r,l,sum=0;
    for(int i=n-1;i>=0;i--){
        r=i;l=i-1;
        while(l>=0 && L[r]+L[l]>S)l--;
        if(l>=0){
            sum+=l+1;
        }
    }
    printf("%d",sum);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值