POJ3663

1.题面

Description

It’s Halloween! Farmer John is taking the cows to a costume party, but unfortunately he only has one costume. The costume fits precisely two cows with a length of S (1 ≤ S ≤ 1,000,000). FJ has N cows (2 ≤ N ≤ 20,000) conveniently numbered 1..N; cow i has length Li (1 ≤ Li ≤ 1,000,000). Two cows can fit into the costume if the sum of their lengths is no greater than the length of the costume. FJ wants to know how many pairs of two distinct cows will fit into the costume.

Input

  • Line 1: Two space-separated integers: N and S
  • Lines 2..N+1: Line i+1 contains a single integer: Li

Output

  • Line 1: A single integer representing the number of pairs of cows FJ can choose. Note that the order of the two cows does not matter.

Sample Input

4 6
3
5
2
1
Sample Output

4

2.思路

  • 先将数组排序
  • 枚举i,利用upper_bound()计算出a[i]的配对个数,累计为cnt
  • 所得个数被重复计算2次,答案除2

3.代码

#include <cstdio>
#include <algorithm>

using namespace std;

int main() {
    int s, n;
    int a[20000 + 5];
    while (scanf("%d %d", &n, &s) != EOF) {
        int cnt = 0;
        for (int i = 0; i < n; i++)
            scanf("%d", &a[i]);
        sort(a, a + n);
        for (int i = 0; i < n; i++){
            int temp = upper_bound(a, a + n, s - a[i])-a;
            if(a[temp-1]>=a[i]) temp--;
            cnt += temp;
        }
        cnt /=2;
        printf("%d\n", cnt);
    }
}

4. 所得

  • 复杂度O(nlogn),主要考察二分查找
  • 过两天不用upper_bound,自己写二分查找再过一遍
  • 虽然题很水,但第一次5分钟AC,有被激励的感觉
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值