Full Binary Tree(有关二叉树)

Description

In computer science, a binary tree is a tree data structure in which each node has at most two children. Consider an infinite full binary tree (each node has two children except the leaf nodes) defined as follows. For a node labelled v its left child will be labelled 2 * v and its right child will be labelled 2 * v + 1. The root is labelled as 1.
 
You are given n queries of the form i, j. For each query, you have to print the length of the shortest path between node labelled i and node labelled j.
 

Input

First line contains n(1 ≤ n ≤ 10^5), the number of queries. Each query consists of two space separated integers i and j(1 ≤ i, j ≤ 10^9) in one line.
 

Output

For each query, print the required answer in one line.
 

Sample Input

5
1 2
2 3
4 3
1024 2048
3214567 9998877

Sample Output

1
2
3
1
44


有关二叉树的问题,简单来说就是找出从 i 到 j(或者说从 j 到 i ) 的路径,从 1 到 2 只需一步,从 2 到 3 需要 2 -> 1 -> 3

 两步.......对二叉树没多少了解,这个题完全可以逻辑推出来。

这题只需要一直把两个数之间大的一方往上推(除 2 或者先减去 1 再除 2(分奇偶) ),总会有相等的时候。



代码如下:

#include <iostream>

using namespace std;

int main()
{
    long long n , i , j , max , min ;
    cin >> n ;
    while(n--)
    {
        int s = 0;
        cin >> i >> j ;
        max = i > j ? i : j ;
        min = j<= i ? j : i ;
        while(max!=min)
        {
            if(max%2==0)
                max /= 2 ;
            else
                max=(max-1) / 2 ;
            s++;
            i = max ;
            j = min ;
            max = i > j ? i : j ;
            min = j <= i ? j : i ;
        }
        cout << s <<endl ;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值