Full Binary Tree(二叉树)

 

Description

In computer science, a binary tree is a tree data structure in which each node has at most two children. Consider an infinite full binary tree (each node has two children except the leaf nodes) defined as follows. For a node labelled v its left child will be labelled 2 * v and its right child will be labelled 2 * v + 1. The root is labelled as 1.

 

You are given n queries of the form i, j. For each query, you have to print the length of the shortest path between node labelled i and node labelled j.

 

Input

First line contains n(1 ≤ n ≤ 10^5), the number of queries. Each query consists of two space separated integers i and j(1 ≤ i, j ≤ 10^9) in one line.

 

Output

For each query, print the required answer in one line.

 

Sample Input

5
1 2
2 3
4 3
1024 2048
3214567 9998877

Sample Output

1
2
3
1
44

题意:本题为二叉树查找左右孩子到共同节点的最短路径,由二叉树模型可知,每次i或j每次除2,都到达上一层节点的位置,左右孩子中大的不断除2,直到i与j相等为止,此时达到共同节点,每次除2用计数器记起来,最后所得便为最短路径。

代码如下:

 

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <math.h>
int main()
{
    int t,a,b,c,s=0;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&a,&b);
        s=0;
        if(a<b)
	{
	    c=a;
            a=b;
            b=c;
	}
        while(a!=b)
        {
            while(a>b)
            {
                a/=2;
                s++;
            }
            c=a;
            a=b;
            b=c;
        }
        printf("%d\n",s);
    }
    return 0;
} <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <math.h>
int main()
{
    int t,a,b,c,s=0;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&a,&b);
        s=0;
        if(a<b)
	{
	    c=a;
            a=b;
            b=c;
	}
        while(a!=b)
        {
            while(a>b)
            {
                a/=2;
                s++;
            }
            c=a;
            a=b;
            b=c;
        }
        printf("%d\n",s);
    }
    return 0;
}

萌新代码,如有不足,请多包含^_^

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值