You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment.
That is, given an array a[1...n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: "What would be the k-th number in a[i...j] segment, if this segment was sorted?"
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.
Input
The first line of the input file contains n --- the size of the array, and m --- the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000).
The second line contains n different integer numbers not exceeding 10 9 by their absolute values --- the array for which the answers should be given.
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).
Output
For each question output the answer to it --- the k-th number in sorted a[i...j] segment.
Sample Input
7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3
Sample Output
5
6
3
Hint
This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.
题解:
给定一个数组,问 [ l , r ]区间内的数按照顺序排列第 k 个数是哪个。划分树讲解
代码:
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <vector>
#include <string>
#include <cmath>
#include <stack>
#include <queue>
#include <map>
#define MAX 0x3f3f3f3f
using namespace std;
typedef long long LL;
int n,m;
int sorted[111111];
int tree[20][111111];
int toleft[20][111111];
void Build(int l,int r,int level)
{
if(l==r)
return ;
int mid=(l+r)/2,isame=mid-l+1;
for(int i=l;i<=r;i++)
if(tree[level][i]<sorted[mid])
isame--;
int left=l,right=mid+1;
for(int i=l;i<=r;i++)
{
if(i==l)
toleft[level][i]=0;
else
toleft[level][i]=toleft[level][i-1];
if(isame>0&&tree[level][i]==sorted[mid]||tree[level][i]<sorted[mid])
{
tree[level+1][left++]=tree[level][i];
toleft[level][i]++;
if(tree[level][i]==sorted[mid])
isame--;
}
else
tree[level+1][right++]=tree[level][i];
}
Build(l,mid,level+1);
Build(mid+1,r,level+1);
}
int query(int level,int left,int right,int l,int r,int k)
{
if(l==r)
return tree[level][l];
int lef;
int tolef;
int mid=(left+right)/2;
if(left==l)
lef=0,tolef=toleft[level][r];
else
{
lef=toleft[level][l-1];
tolef=toleft[level][r]-lef;
}
if(tolef>=k)
{
int newleft=lef+left;
int newright=newleft+tolef-1;
return query(level+1,left,mid,newleft,newright,k);
}
else
{
int newleft=mid+1+(l-left-lef);
int newright=newleft+(r-l+1-tolef)-1;
return query(level+1,mid+1,right,newleft,newright,k-tolef);
}
}
int main()
{
cin >> n >> m;
for(int i=1;i<=n;i++)
{
scanf("%d",&tree[0][i]);
sorted[i]=tree[0][i];
}
sort(sorted+1,sorted+n+1);
Build(1,n,0);
for(int i=1;i<=m;i++)
{
int x,y,k;
scanf("%d%d%d",&x,&y,&k);
printf("%d\n",query(0,1,n,x,y,k));
}
return 0;
}