问题 C: Milking Order
时间限制: 3 Sec 内存限制: 128 MB
提交: 127 解决: 44
[提交] [状态] [讨论版] [命题人:admin]
题目描述
Farmer John's N cows (1≤N≤105), numbered 1…N as always, happen to have too much time on their hooves. As a result, they have worked out a complex social hierarchy related to the order in which Farmer John milks them every morning.
After weeks of study, Farmer John has made M observations about his cows' social structure (1≤M≤50,000). Each observation is an ordered list of some of his cows, indicating that these cows should be milked in the same order in which they appear in this list. For example, if one of Farmer John's observations is the list 2, 5, 1, Farmer John should milk cow 2 sometime before he milks cow 5, who should be milked sometime before he milks cow 1.
Farmer John's observations are prioritized, so his goal is to maximize the value of X for which his milking order meets the conditions outlined in the first X observations. If multiple milking orders satisfy these first X conditions, Farmer John believes that it is a longstanding tradition that cows with lower numbers outrank those with higher numbers, so he would like to milk the lowest-numbered cows first. More formally, if multiple milking orders satisfy these conditions, Farmer John would like to use the lexicographically smallest one. An ordering x is lexicographically smaller than an ordering y if for some j, xi=yi for all i<j and xj<yj (in other words, the two orderings are identical up to a certain point, at which x is smaller than yy).
Please help Farmer John determine the best order in which to milk his cows.
输入
The first line contains N and M. The next M lines each describe an observation. Line i+1 describes observation i, and starts with the number of cows mi listed in the observation followed by the list of mimi integers giving the ordering of cows in the observation. The sum of the mi's is at most 200,000.
输出
Output N space-separated integers, giving a permutation of 1…N containing the order in which Farmer John should milk his cows.
样例输入
4 3
3 1 2 3
2 4 2
3 3 4 1
样例输出
1 4 2 3
提示
Here, Farmer John has four cows and should milk cow 1 before cow 2 and cow 2 before cow 3 (the first observation), cow 4 before cow 2 (the second observation), and cow 3 before cow 4 and cow 4 before cow 1 (the third observation). The first two observations can be satisfied simultaneously, but Farmer John cannot meet all of these criteria at once, as to do so would require that cow 1 come before cow 3 and cow 3 before cow 1.
This means there are two possible orderings: 1 4 2 3 and 4 1 2 3, the first being lexicographically smaller.
洛谷上有翻译的版本 这里、
如果Farmer John的一次观察结果是序列2、5、1,Farmer John应该在给奶牛5挤奶之前的某个时刻给奶牛2挤奶,在给奶牛1挤奶之前的某个时刻给奶牛5挤奶。
看了下拓扑排序的定义,这里是符合的
那么
Farmer John的观察结果是按优先级排列的,所以他的目标是最大化 X的值,使得他的挤奶顺序能够符合前 X个观察结果描述的状态
这里就要考虑二分了,
后面还要求字典序,那么优先队列维护
拓扑
将一个有向图转化为一个线性 的,emm,大概就那样的一个东西
在这个线性 的表里,对于两个点,i,j(不妨设i<j),如果i与j之间有边
那么一定是i指向j的边,
例如将点看成事情,边看成完成事情 的先后顺序关系,那么拓扑过后的图
i事情一定要在j事情完成之前完成,这个在很多领域都有应用
具体拓扑的实现就是
1找一个没有任何点指向的点,删掉,(如果要输出拓扑的话在这里输出)
与此同时删掉它指向的边
2重复1操作直到下面两种情况
1’找不到没有指向的点(入度为0)(说明有环)
2’所有点都输出了(拓扑完成)
代码转自洛谷
#include<bits/stdc++.h>
using namespace std;
struct node{
int x;
node(int b):x(b){}
bool operator < (const node &a) const
{
return a.x < x;
}
};
const int L=50005;
int n,m,l,r,ind[L*2],ans;
vector<int>p[L*2],Map[L*2];
priority_queue<node>g;
void build(int x)
{
memset(ind,0,sizeof(ind));
memset(Map,0,sizeof(Map));
for(int i=1;i<=x;i++)
{
for(int j=0;j<p[i].size()-1;j++)
{
Map[p[i][j]].push_back(p[i][j+1]);
ind[p[i][j+1]]++;
}
}
}
int topo()
{
int num=0;
for(int i=1;i<=n;i++)
{
if(!ind[i])
{
g.push(i);
num++;
}
}
int temp;
while(!g.empty())
{
temp=g.top().x;
g.pop();
for(int i=0;i<Map[temp].size();i++)
{
ind[Map[temp][i]]--;
if(!ind[Map[temp][i]])
{
g.push(Map[temp][i]);
num++;
}
}
}
if(num==n)
return 1;
return 0;
}
int find_ans(int x)
{
build(x);
for(int i=1;i<=n;i++)
if(!ind[i])
g.push(i);
int temp;
while(!g.empty())
{
temp=g.top().x;
printf("%d ",temp);
g.pop();
for(int i=0;i<Map[temp].size();i++)
{
ind[Map[temp][i]]--;
if(!ind[Map[temp][i]])
{
g.push(Map[temp][i]);
}
}
}
}
int check(int x)
{
build(x);
return topo();
}
int main()
{
scanf("%d%d",&n,&m);
for(int i=1;i<=m;i++)
{
int t;
scanf("%d",&t);
for(int j=1;j<=t;j++)
{
int q;
scanf("%d",&q);
p[i].push_back(q);
}
}
l=0,r=m+1;
while(r>=l)
{
int mid=(l+r)>>1;
if(check(mid)==1)
{
l=mid+1;
ans=mid;
}
else
r=mid-1;
}
find_ans(ans);
return 0;
}