POJ 1947 Rebuilding Roads

Rebuilding Roads
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 7940 Accepted: 3534

Description

The cows have reconstructed Farmer John's farm, with its N barns (1 <= N <= 150, number 1..N) after the terrible earthquake last May. The cows didn't have time to rebuild any extra roads, so now there is exactly one way to get from any given barn to any other barn. Thus, the farm transportation system can be represented as a tree.

Farmer John wants to know how much damage another earthquake could do. He wants to know the minimum number of roads whose destruction would isolate a subtree of exactly P (1 <= P <= N) barns from the rest of the barns.

Input

* Line 1: Two integers, N and P

* Lines 2..N: N-1 lines, each with two integers I and J. Node I is node J's parent in the tree of roads.

Output

A single line containing the integer that is the minimum number of roads that need to be destroyed for a subtree of P nodes to be isolated.

Sample Input

11 6
1 2
1 3
1 4
1 5
2 6
2 7
2 8
4 9
4 10
4 11

Sample Output

2

Hint

[A subtree with nodes (1, 2, 3, 6, 7, 8) will become isolated if roads 1-4 and 1-5 are destroyed.]


题目的意思:

给你一棵树,求通过求通过删除最少的边,使得剩余子树有给定的节点数。

d[i][j]表示以i为根的子树删除j个结点所需删除的最小边数。

需要注意的是所要求得到的剩余子树没有要求一定包括整棵树的根结点。

#include<cstdio>
#include<cstring>
#include<vector>

using namespace std;

#define Min_(a,b)	(a<b?a:b)

int N,P,flag,Min;
int d[160][160],s[160];								//s[i]存下以i为根的子树所拥有的最多结点数
bool vis[160];
vector<int> son[160];

void DFS(int x)
{
	int i,j,k,v;
	if(x==flag)													
		s[x]=0;
	else
		s[x]=1;
	d[x][0]=0;
	for(i=0;i<son[x].size();i++)
	{
		v=son[x][i];
		DFS(v);
		s[x]+=s[v];
		for(j=N;j>=0;j--)
			for(k=0;k<=j;k++)
			{
				if(d[x][j-k]!=-1 && d[v][k]!=-1)
				{
					if(d[x][j]==-1)
						d[x][j]=d[x][j-k]+d[v][k];
					else
						d[x][j]=Min_(d[x][j],d[x][j-k]+d[v][k]);
				}
			}
	}
	if(x!=flag)
	{
		d[x][s[x]]=1;
		if(s[x]>P)
			Min=d[x][s[x]-P]+1<Min?d[x][s[x]-P]+1:Min;
		else if(s[x]==P)
			Min=1;
	}
}

int main()
{
	int i,u,v;

	while(scanf("%d%d",&N,&P)==2)
	{
		memset(vis,0,sizeof(vis));
		for(i=1;i<=N;i++)
			son[i].clear();
		for(i=1;i<N;i++)
		{
			scanf("%d%d",&u,&v);
			son[u].push_back(v);
			vis[v]=1;
		}

		memset(d,-1,sizeof(d));
		Min=1000;
		for(i=1;i<=N;i++)
		{
			if(!vis[i])
			{
				flag=i;										//flag标记根节点
				DFS(i);
			}
		}
		if(d[flag][N-P]<Min)
			Min=d[flag][N-P];
		printf("%d\n",Min);

	}

	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值