H - Rebuilding Roads

就是状态的寻找不易想到。题目大意:给你一颗树,对树进行裁剪,问得到p个节点最少裁减多少次

题目分析:

用dp[i][j]表示以i为根结点,得到j个节点最少裁剪的次数

由于每个节点的当前子树是否裁剪是不确定的,因此就有两种情况:

选k为r的孩子之一

(1)裁剪当前子树k:则dp【r】【p】+1

(2)不裁剪当前子树k:则dp【r】【p】=dp【r】【i】+dp【k】【p-i】(0<=i<=p)。。

其中i为r上的节点,不包括子树k上的节点

而要找最小的所以就要遍历r的所有的孩子,dp[r][p] = min(dp[r][i] + dp[k][p-i]) (k为r的孩子);

(3)3.总上dp[r][p] = min(1, 2),第一种和第二种最小的一个

 

题目:

 

The cows have reconstructed Farmer John's farm, with its N barns (1 <= N <= 150, number 1..N) after the terrible earthquake last May. The cows didn't have time to rebuild any extra roads, so now there is exactly one way to get from any given barn to any other barn. Thus, the farm transportation system can be represented as a tree. 

Farmer John wants to know how much damage another earthquake could do. He wants to know the minimum number of roads whose destruction would isolate a subtree of exactly P (1 <= P <= N) barns from the rest of the barns.

Input

* Line 1: Two integers, N and P 

* Lines 2..N: N-1 lines, each with two integers I and J. Node I is node J's parent in the tree of roads. 

Output

A single line containing the integer that is the minimum number of roads that need to be destroyed for a subtree of P nodes to be isolated. 

Sample Input

11 6
1 2
1 3
1 4
1 5
2 6
2 7
2 8
4 9
4 10
4 11

Sample Output

2

Hint

[A subtree with nodes (1, 2, 3, 6, 7, 8) will become isolated if roads 1-4 and 1-5 are destroyed.] 

 

 

代码:

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<cmath>
using namespace std;
struct node
{
    int to;
    int next;
};
int dp[155][155];
int brother[155];
int son[155];
int n,p;
void dfs(int r)
{
    for(int i=0;i<=p;i++)
    {
        dp[r][i]=1000000000;
    }
    dp[r][1]=0;
    for(int i=son[r];i!=-1;i=brother[i])
    {
        int v=i;
        dfs(v);
        for(int j=p;j>=0;j--)
        {
            int tmp=dp[r][j]+1;
            for(int k=0;k<=j;k++)
            {
                tmp=min(tmp,dp[v][j-k]+dp[r][k]);
            }
            dp[r][j]=tmp;
        }
    }
}
int main()
{
    int u,v;
    while(~scanf("%d%d",&n,&p))
    {
        int cnt=0;
        memset(son,-1,sizeof(son));
        for(int i=1;i<n;i++)
        {
            scanf("%d%d",&u,&v);
            brother[v]=son[u];//u为父节点,v的兄弟就是u的孩子
            son[u]=v;


        }
        int ans;
        dfs(1);
        ans=dp[1][p];
        for(int j=1;j<=n;j++)
        {
            if(ans>dp[j][p])
                ans=dp[j][p]+1;//不要忘记减去父亲的那条(除了根结点)
        }
        cout<<ans<<endl;
    }
    return 0;


}

http://blog.csdn.net/ctxdecs/article/details/23367145

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值