Rebuilding Roads--树形DP

Rebuilding Roads
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 11497 Accepted: 5278

Description

The cows have reconstructed Farmer John's farm, with its N barns (1 <= N <= 150, number 1..N) after the terrible earthquake last May. The cows didn't have time to rebuild any extra roads, so now there is exactly one way to get from any given barn to any other barn. Thus, the farm transportation system can be represented as a tree. 

Farmer John wants to know how much damage another earthquake could do. He wants to know the minimum number of roads whose destruction would isolate a subtree of exactly P (1 <= P <= N) barns from the rest of the barns.

Input

* Line 1: Two integers, N and P 

* Lines 2..N: N-1 lines, each with two integers I and J. Node I is node J's parent in the tree of roads. 

Output

A single line containing the integer that is the minimum number of roads that need to be destroyed for a subtree of P nodes to be isolated. 

Sample Input

11 6
1 2
1 3
1 4
1 5
2 6
2 7
2 8
4 9
4 10
4 11

Sample Output

2

Hint

[A subtree with nodes (1, 2, 3, 6, 7, 8) will become isolated if roads 1-4 and 1-5 are destroyed.] 
题目链接:http://poj.org/problem?id=1947


题目的大体意思是给你一个树形结构,求要得到k的节点至少要剪掉几个树枝。


经典的树形dp,想的差不多,然后敲了个代码,到中间发现卡住了,然后就卡住了。。。无奈,去搜了题解,好吧,我的思路错了,dp[i][j]表示以i为根得到子树含有j个节点的最少步数。

题解上有一段讲的特别好:

对于i的子树k:

1.不加子树k,dp[s][i] = dp[s][i] + 1 (不加子树k,相当于删去一条边)

2.加子树k,dp[s][i] = min(dp[s][j] + dp[k][i - j]) (1<= j <= i) (以s为根的树的结点数加上其子树的结点数等于i)

最后答案就是在dp[i][m]中取小,要注意的一点是,如果i不是根,值还需要+1,因为要脱离原来的根,还要去掉一条边

这里需要注意,dp过程是自下而上的,也就是从叶子到根,而不是从根到叶子


渣渣的代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#define inf 0x3fffffff
using namespace std;
struct node{
    int v,pre;
}edge[10000];
int p[10000],nEdge;
int n,m;
int fa[10000];
void Init(){
    memset(p,-1,sizeof(p));
    memset(fa,-1,sizeof(fa));
    nEdge=0;
}
int dp[200][200];
void connect(int u,int v){
    edge[nEdge].v=v;
    edge[nEdge].pre=p[u];
    p[u]=nEdge++;
}
void dfs(int u){
    for(int i=0;i<=m;i++){
        dp[u][i]=inf;
    }
    dp[u][1]=0;
    for(int i=p[u];~i;i=edge[i].pre){
        int v=edge[i].v;
        dfs(v);
        for(int j=m;j>=1;j--){
            for(int k=0;k<j;k++){
                if(k){
                    dp[u][j]=min(dp[u][j],dp[u][j-k]+dp[v][k]);
                }
                else{
                    dp[u][j]=dp[u][j]+1;
                }
            }
        }
    }
}
int main(){
    while(~scanf("%d%d",&n,&m)){
        Init();
        for(int i=1;i<n;i++){
            int u,v;
            scanf("%d%d",&u,&v);
            connect(u,v);
            fa[v]=u;
        }
        int root=1;
        while(fa[root]!=-1){
            root=fa[root];
        }
        dfs(root);
        //cout<<"-----------"<<endl;
        int ans=dp[root][m];
        for(int i=1;i<=n;i++){
            ans=min(ans,dp[i][m]+1);
        }
        printf("%d\n",ans);
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值