Median 二分

Median 


Given N numbers, X1, X2, ... , XN, let us calculate the difference of every pair of numbers: ∣Xi - Xj∣ (1 ≤ i < j ≤ N). We can get C(N,2) differences through this work, and now your task is to find the median of the differences as quickly as you can!


Note in this problem, the median is defined as the (m/2)-th  smallest number if m,the amount of the differences, is even. For example, you have to find the third smallest one in the case of m = 6.


Input
The input consists of several test cases.
In each test case, N will be given in the first line. Then N numbers are given, representing X1, X2, ... , XN, ( Xi ≤ 1,000,000,000  3 ≤ N ≤ 1,00,000 )


Output
For each test case, output the median in a separate line.


Sample Input
4
1 3 2 4
3
1 10 2
Sample Output
1
8


题意:一个数组每两个数相减取绝对值,求所有绝对值组成的数组的中数


题解:二分答案,判断小于等于mid的数是否大于所有绝对值个数的一半,记住查找时应用upper_bound


//#include<bits/stdc++.h>
#include<iostream>
#include<algorithm>
#include<cstdio>
#define MT(a,b) memset(a,0,sizeof(a))
#define ll long long
using namespace std;
const int maxn = 1e5+5;
int a[maxn];///dp[maxn][20];
int n,m;


bool check(int x)
{
    int sum=0;
    for(int i=0;i<n-1;i++)
    {
        int p=upper_bound(a,a+n,a[i]+x)-a;
        sum+=p-i-1;
    }
    return sum>=(m+1)/2;
}


int main()
{
    while(cin>>n)
    {
        for(int i=0;i<n;i++)scanf("%d",&a[i]);
        sort(a,a+n);
        m=n*(n-1)/2;
        int l=0,r=a[n-1]-a[0],ans=(l+r)/2;
        while(l<=r)
        {
            int mid=(l+r)/2;
            if(check(mid)) ans=mid,r=mid-1;
            else l=mid+1;
        }
        cout<<ans<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值