Median (Binery Search)

Given N numbers, X1, X2, … , XN, let us calculate the difference of every pair of numbers: ∣Xi - Xj∣ (1 ≤ i < j ≤ N). We can get C(N,2) differences through this work, and now your task is to find the median of the differences as quickly as you can!

Note in this problem, the median is defined as the (m/2)-th smallest number if m,the amount of the differences, is even. For example, you have to find the third smallest one in the case of m = 6.

Input
The input consists of several test cases.
In each test case, N will be given in the first line. Then N numbers are given, representing X1, X2, … , XN, ( Xi ≤ 1,000,000,000 3 ≤ N ≤ 1,00,000 )

Output
For each test case, output the median in a separate line.

Sample Input
4
1 3 2 4
3
1 10 2
Sample Output
1
8

题意:给N个数,求他们之间差值绝对值的中间值。

做法:二分两次,第一次二分差值,看这个差值能不能达到差值总数的一半,这个判断方法是对于每个xi,查找有多少个值大于等于xi加上这个差值,也可以用二分。

注意:当二分对象是离散的情况的处理方式,上界和下界的确定,
upperbound函数的应用。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#define maxn 100010

using namespace std;

int x[maxn];
int n,m;
bool solve(int d)
{
    int ans=0;
    int t;
    for(int i=0;i<n;i++)
    {
        t=upper_bound(x,x+n,x[i]+d)-x;
        ans+=t-1-i;
    }
    return ans>=(m+1)/2;
}


int main()
{
    while(scanf("%d",&n)==1)
    {
        m=(n-1)*n/2;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&x[i]);
        }
        sort(x,x+n);
        int st=0;
        int end=x[n-1]-x[0];
        int mid=0;
        int ans;//这种处理方式很重要,保证了ans一定满足solve(ans)
        while(end>=st)
        {
            mid=(end+st)/2;
            if(solve(mid)){end=mid-1;ans=mid;}
            else st=mid+1;
        }
        cout<<ans<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值