题目正文
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.
This year, they decide to leave this lovely job to you.
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.
A test case with N = 0 terminates the input and this test case is not to be processed.
Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0
Sample Output
red
pink
题意
输出出现最多次的颜色即可
代码
代码:
//1.输入n,定义一个映射队列map,一个为字符类型记录颜色,另一个为整型记录数量
//2.定义一个字符串,一个颜色的变量,一个颜色数量的变量并赋值
//3.循环输入各种颜色,并写入map中
//4.循环统计颜色的数量可以用迭代器的方法iterator,
//5.map<string,int>::iterator it=m.begin();it!=m.end();it++
//6.判断是否为最大值(*it).second>maxn,当大于时,把最大值重新赋值
#include<stdio.h>
#include<iostream>
#include<map>
using namespace std;
int main()
{
int n;
while(cin>>n&&n)
{
map<string,int> m;
string str,maxx;
int maxn=-10;
for(int i=0;i<n;i++)
{
cin>>str;
m[str]++;
}
for(map<string,int>::iterator it=m.begin();it!=m.end();it++)
{
if((*it).second>maxn)
{
maxn=(*it).second;
maxx=(*it).first;
}
}
cout<<maxx<<endl;
}
return 0;
}
总结
运用map存储出现的颜色和个数,最后遍历出现最多次的颜色,输出即可。