UVa12716 GCD XOR

Description


Given an integer N, nd how many pairs (A; B) are there such that: gcd(A; B) = A xor B where
1<=B<=A<=N.
Here gcd(A; B) means the greatest common divisor of the numbers A and B. And A xor B is the
value of the bitwise xor operation on the binary representation of A and B.
Input
The rst line of the input contains an integer T (T 10000) denoting the number of test cases. The

following T lines contain an integer N (1 N 30000000).

Output

For each test case, print the case number rst in the format, `Case X:' (here, X is the serial of the

input) followed by a space and then the answer for that case. There is no new-line between cases.
Explanation

Sample 1:

 For N = 7, there are four valid pairs: (3, 2), (5, 4), (6, 4) and (7, 6)

Sample Input


2

7

20000000


Sample Output


Case 1: 4

Case 2: 34866117


xor有个性质:a xor b = c ,那么  a xor c  =b;因此,可以枚举a和c,然后算出b=a xor c ,再验证是否有gcd(a,b)=c;

而通过列举几组三元组,我们可以发现c=a-b ,因此,我们只需枚举a和c 取b=a-c ,看是否有c= a xor b 即可。


#include <iostream>
#include <cstdio>
#include <map>
#include <cmath>
#include <algorithm>
#include <cstring>
#include <string>
#define LL long long
using namespace std;
#define maxn 30000005
int s[maxn];
void p()
{
    int n=maxn/2;
    memset(s,0,sizeof(s));
    for(int c=1;c<=n;c++){
        for(int a=c+c;a<=maxn;a+=c){
            int b=a-c;
            if((a^b)==c){
                s[a]++;
            }
        }
    }
    for(int i=2;i<maxn;i++){
        s[i]+=s[i-1];
    }
}
int main()
{
    int t,n,ca=1;
    p();
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        printf("Case %d: %d\n",ca++,s[n]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值