SPOJ7001 Visible Lattice Points 莫比乌斯反演+分块+前缀和

Description
Consider a N*N*N lattice. One corner is at (0,0,0) and the opposite one is at (N,N,N). How many lattice points are visible from corner at (0,0,0) ? A point X is visible from point Y iff no other lattice point lies on the segment joining X and Y. 
 
Input : 
The first line contains the number of test cases T. The next T lines contain an interger N 
 
Output : 
Output T lines, one corresponding to each test case. 
 
Sample Input : 




 
Sample Output : 

19 
175 
 
Constraints : 
T <= 50 

1 <= N <= 1000000


题意:1<=X,Y,Z<=n,求GCD(X,Y,Z)=1 的(X,Y,Z)组数,由莫比乌斯反演可得,结果为∑mu[i]*(n/i)*(n/i)*(n/i)即可,

但是,这个没有考虑X,Y,Z轴上的三个点,以及三个二维平面上的点,后者把上面的一个 (n/i) 改成 (n/i+3) 即可。


#include <iostream>
#include <cstdio>
#include <map>
#include <cmath>
#include <algorithm>
#include <cstring>
#include <string>
using namespace std;
#define LL long long
#define maxn 1000100
bool v[maxn];
int prime[maxn],mu[maxn],sum[maxn];

void Moblus()
{
    memset(v,false,sizeof(v));
    mu[1]=1;
    sum[1]=1;
    sum[0]=0;
    int tot=0;
    for(int i=2;i<=maxn;i++)
    {
        if(!v[i]){
            prime[tot++]=i;
            mu[i]=-1;
        }
        for(int j=0;j<tot;j++){
            if(i*prime[j]>maxn) break;
            v[i*prime[j]]=true;
            if(i%prime[j]==0){
                mu[i*prime[j]]=0;
                break;
            }else{
                mu[i*prime[j]]=-mu[i];
            }
        }
        sum[i]=sum[i-1]+mu[i];
    }
}
int main()
{
    int t,n;
    Moblus();
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        LL ans=3;
        for(int i=1,last;i<=n;i=last+1){
            last=n/(n/i);
            ans+=(LL)(sum[last]-sum[i-1])*(n/i)*(n/i)*((n/i)+3);
        }
        printf("%lld\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值