题目描述
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute * Teleporting: FJ can move from any point X to the point 2 × X in a single minute. If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
输入
Line 1: Two space-separated integers: N and K
输出
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
示例输入
5 17
示例输出
4
题目大意是给你两个数N和K,求从N到K的最小步数。分三个方向BFS即可。
代码
#include <iostream>
#include <queue>
#define MAX 100001
using namespace std;
queue<int> x;
bool visited[MAX];
int step[MAX];
int BFS(int n,int k)
{
int head,next;
x.push(n);
visited[n]=1;
step[n]=0;
while(!x.empty())
{
head=x.front();
x.pop();
for(int i=0;i<3;i++)
{
if(i==0) next=head-1;
else if(i==1) next=head+1;
else next=head*2;
if(next>MAX||next<0) continue;
if(!visited[next])
{
x.push(next);
step[next]=step[head]+1;
visited[next]=true;
}
if(next==k) return next[step];
}
}
}
int main()
{
ios::sync_with_stdio(false);
int n,k;
cin>>n>>k;
if(n>=k)
cout<<n-k<<endl;
else
cout<<BFS(n,k)<<endl;
return 0;
}