【HD 1242】Rescue (BFS)

Rescue

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26491 Accepted Submission(s): 9379

Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel’s friends want to save Angel. Their task is: approach Angel. We assume that “approach Angel” is to get to the position where Angel stays. When there’s a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. “.” stands for road, “a” stands for Angel, and “r” stands for each of Angel’s friend.

Process to the end of the file.

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing “Poor ANGEL has to stay in the prison all his life.”

Sample Input
7 8
#.#####.
#.a#..r.
#..#x...
..#..#.#
#...##..
.#......
........


Sample Output
13

Author
CHEN, Xue

Source
ZOJ Monthly, October 2003

Recommend
Eddy | We have carefully selected several similar problems for you: 1240 1016 1010 1072 1241

————————————————————————————————————————————————————

BFS的题目,题解就偷懒不写了,具体可以看这个传送门 ->{ 类型总结 }
————————————————————————————————————————————————————

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>

using namespace std;

const int MAX_N = 205;
char map[MAX_N][MAX_N];
int vis[MAX_N][MAX_N];
int dir[4][2]={1,0,0,1,-1,0,0,-1};
int n,m;
struct node
{
    int x,y;
    int step;
    friend bool operator < (node a,node b)
    {
        return a.step > b.step;
    }
}st,ed;

int judge(int x,int y)
{
    if( 0<=x && x<n && 0<=y && y<m && map[x][y] != '#' )
        return 1;
    else
        return 0;
}

int bfs(int x,int y)
{
    priority_queue<node>q;
    while( !q.empty() )
    {
        q.pop();
    } 
    memset(vis,0,sizeof(vis));
    st.x=x;
    st.y=y;
    st.step=0;
    vis[st.x][st.y]=1;
    q.push(st);
    while( q.size() )
    {
        st=q.top();
        if( map[st.x][st.y] == 'a' )
            return st.step;
        q.pop();
        for(int i=0; i<4; i++)
        {
            ed.x = st.x+dir[i][0];
            ed.y = st.y+dir[i][1];
            if( judge(ed.x,ed.y) && !vis[ed.x][ed.y] )
            {
                if(map[ed.x][ed.y]=='x')
                    ed.step=st.step+2;
                else
                    ed.step=st.step+1;
                vis[ed.x][ed.y]=1;
                q.push(ed);
            }
        }
    }
    return -1;
}
int main()
{
    while( ~scanf("%d%d",&n,&m) )
    {
        int i,j;
        int x=0;
        int y=0;
        int ans=0;
        for( i=0; i<n; i++ )
        {
            scanf("%s",map[i]);
            for( j=0; j<m; j++ )
            {
                if( map[i][j] == 'r' )
                {
                    x=i;
                    y=j;
                    break;
                }
            }
        }
        ans = bfs(x,y);
        if( ans == -1 )
            printf("Poor ANGEL has to stay in the prison all his life.\n");
        else
            printf("%d\n",ans);
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值