1028 List Sorting

44 篇文章 0 订阅

description

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤10
5
) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student’s record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID’s; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID’s in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98
Sample Output 2:
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 9

Sample Output 3:

000002 James 9
000001 Zoe 60
000007 James 85
000010 Amy 90

idea

  • c == 1 id从小到大
  • c == 2
    • name不同,字典序从小到大
    • id从小到大
  • c == 3
    • grade不同,从小到大
    • id从小到大

solution

#include <stdio.h>
#include <algorithm>
#include <string.h>
using namespace std;
struct student{
	int grade;
	char id[10], name[10];
} stu[100010]; 
bool cmp1(student s1, student s2){
	return strcmp(s1.id, s2.id) < 0;
}
bool cmp2(student s1, student s2){
	if(strcmp(s1.name, s2.name) != 0) return strcmp(s1.name, s2.name) < 0;
	else return strcmp(s1.id, s2.id) < 0;
}
bool cmp3(student s1, student s2){
	if(s1.grade != s2.grade) return s1.grade < s2.grade;
	else return strcmp(s1.id, s2.id) < 0;
}
int main(){
	int n, c, num;
	scanf("%d%d", &n, &c);
	for(num = 0; num < n; num++){
		scanf("%s%s%d", &stu[num].id, &stu[num].name, &stu[num].grade);
	}
	if(c == 1) sort(stu, stu + num, cmp1);
	else if(c == 2) sort(stu, stu + num, cmp2);
	else sort(stu, stu + num, cmp3);
	for(int i = 0; i < n; i++){
		printf("%s %s %d", stu[i].id, stu[i].name, stu[i].grade);
		if(i != n - 1) printf("\n");
	}
	return 0;
}

在这里插入图片描述

没了奔头就会颓,颓未来就容易没有奔头。
人高效的生活就会有更多积累,就容易有收获。
既然循坏总归要开始,那我要选择积极的可能。
the easy way, or the free way

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值