八数码难题
题目描述
在 3 × 3 3\times 3 3×3 的棋盘上,摆有八个棋子,每个棋子上标有 1 1 1 至 8 8 8 的某一数字。棋盘中留有一个空格,空格用 0 0 0 来表示。空格周围的棋子可以移到空格中。要求解的问题是:给出一种初始布局(初始状态)和目标布局(为了使题目简单,设目标状态为 123804765 123804765 123804765),找到一种最少步骤的移动方法,实现从初始布局到目标布局的转变。
输入格式
输入初始状态,一行九个数字,空格用 0 0 0 表示。
输出格式
只有一行,该行只有一个数字,表示从初始状态到目标状态需要的最少移动次数。保证测试数据中无特殊无法到达目标状态数据。
样例 #1
样例输入 #1
283104765
样例输出 #1
4
提示
样例解释
图中标有 0 0 0 的是空格。绿色格子是空格所在位置,橙色格子是下一步可以移动到空格的位置。如图所示,用四步可以达到目标状态。
并且可以证明,不存在更优的策略。
solution
最小操作次数问题考虑bfs
#include<iostream>
#include<queue>
#include<map>
#include<string>
#include<algorithm>
using namespace std;
string begin, end, t;
map<string, int> mp;
int n, d, k, x, y;
int X[4] = {-1, 1, 0, 0};//方向偏移数组
int Y[4] = {0, 0, -1, 1};//上 下 左 右
int bfs(string s){
queue<string> q;//辅助队列
q.push(s);//初始状态入队
while(!q.empty()){
t = q.front();//访问队首元素
q.pop();//队首元素出队
if(t == end) return mp[t];//首次到达目标状态 ,得到最少操作次数
k = t.find('0');//找到空位置0在状态串中的位置
for(int i = 0; i < 4; i++){
x = k / 3 + X[i];//一维坐标转二维坐标
y = k % 3 + Y[i];
if(x < 0 || x >= 3 || y < 0 || y >= 3) continue;//非法坐标
d = mp[t];
swap(t[k], t[x * 3 + y]);//交换
if(!mp.count(t)) {//确保无重复操作
mp[t] = d + 1;
q.push(t);//把该状态入队
}
swap(t[k], t[x * 3 + y]); //还原,以判断下一个相邻变换
}
}
}
int main(){
cin >> begin;
end = "123804765";
cout << bfs(begin);
return 0;
}
青蛙跳杯子(友好版)
solution
end作为变量名会有歧义,过不了蓝桥杯编译,以后要避开哦
#include<iostream>
#include<string>
#include<queue>
#include<map>
#include<algorithm>
using namespace std;
string start, aim, t;
map<string, int> mp;
int X[6] = {-3, -2, -1, 1, 2, 3};
int n, k, p, d;
int bfs(string s){
queue<string> q;
q.push(s);
while(!q.empty()){
t = q.front();
q.pop();
if(t == aim) return mp[t];
k = t.find('*');
for(int i = 0; i < 6; i++){
p = k + X[i];
if(p < 0 || p >= n) continue;
d = mp[t];
swap(t[k], t[p]);
if(!mp.count(t)){
mp[t] = d + 1;
q.push(t);
}
swap(t[k], t[p]);
}
}
}
int main(){
cin >> start >> aim;
n = start.size();
cout << bfs(start);
return 0;
}