ACboy was kidnapped

ACboy was kidnapped!!
he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor 
As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy."
The problems of the monster is shown on the wall:
Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very hapapy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").
and the following N lines, each line is "IN M" or "OUT", (M represent a integer).
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!

Input

The input contains multiple test cases.
The first line has one integer,represent the number oftest cases.
And the input of each subproblem are described above.

Output

For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.
Sample Input
4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT
Sample Output
1
2
2
1
1
2
None
2
3

代码如下:(过不了关但是可以提供思路) (AC代码在下面)

#include<bits/stdc++.h>//万能头文件
#include<iostream>//过vj用下列头文件 
#include<stack>
#include<queue>
using namespace std;
int main() {
	stack<int> v;//栈 先进后出->FILO
	queue<int> u;//队列 先进先出->FIFO
	int n;
	cin>>n;
	while(n--) {
		int t;
		string a;
		cin>>t>>a;
		if(a=="FIFO") { //当为FIFO时 使用queue 命名为u
			while(t--) {
				string ch;
				cin>>ch;
				if(ch=="IN") { //"IN"为插入
					int x;
					cin>>x;
					u.push(x);
				}
				if(ch=="OUT") { //"OUT"为输出
					if(u.empty()) cout<<"None"<<endl;//判定是否为空
					else {
						cout<<u.front()<<endl;//注意队列队头的输出为front
						u.pop();//队头出队
					}
				}
			}
		}
		if(a=="FILO") { //当为FIFO时 使用stack 命名为v
			while(t--) {
				string ch;
				cin>>ch;
				if(ch=="IN") { //"IN"为插入
					int x;
					cin>>x;
					v.push(x);
				}
				if(ch=="OUT") { //"OUT"为输出
					if(v.empty()) cout<<"None"<<endl;
					else {
						cout<<v.top()<<endl;//栈输出栈顶为top
						v.pop();//栈顶出栈
					}
				}
			}
		}
	}
	system("pasue");
	return 0;
}

AC代码如下: 

#include<cstdio>
#include<cstring>
#include<stack>
#include<queue>
using namespace std;
 
stack<int>a;
queue<int>b;
int main()
{
	char s[10100],s1[10];
	int t,c,n;
	scanf("%d",&t);	
	while(t--)
	{		
		scanf("%d %s",&n,s);
		if(strcmp(s,"FIFO")==0)
		{
			while(n--)
			{
				scanf("%s",s1);
				if(strcmp(s1,"IN")==0)
				{
					scanf("%d",&c);
					b.push(c);
				}
				else
				{
					if(b.empty()) printf("None\n");
					else 
					{
						printf("%d\n",b.front());
						b.pop();
					}
				}
			}		
		}
		else
		{
			while(n--)
			{
				scanf("%s",s1);
				if(strcmp(s1,"IN")==0)
				{
					scanf("%d",&c);
					a.push(c);
				}
				else
				{
					if(a.empty()) printf("None\n");
					else 
					{
						printf("%d\n",a.top());
						a.pop();
					}
				}								
			}
		}
		while(!a.empty()) a.pop();
		while(!b.empty()) b.pop();
	}
	return 0;
}


 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值