HDU 5831 Rikka with Parenthesis II (括号匹配)

80 篇文章 0 订阅


Rikka with Parenthesis II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1609    Accepted Submission(s): 707


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Correct parentheses sequences can be defined recursively as follows:
1.The empty string "" is a correct sequence.
2.If "X" and "Y" are correct sequences, then "XY" (the concatenation of X and Y) is a correct sequence.
3.If "X" is a correct sequence, then "(X)" is a correct sequence.
Each correct parentheses sequence can be derived using the above rules.
Examples of correct parentheses sequences include "", "()", "()()()", "(()())", and "(((())))".

Now Yuta has a parentheses sequence  S , and he wants Rikka to choose two different position  i,j  and swap  Si,Sj

Rikka likes correct parentheses sequence. So she wants to know if she can change S to a correct parentheses sequence after this operation.

It is too difficult for Rikka. Can you help her?
 

Input
The first line contains a number t(1<=t<=1000), the number of the testcases. And there are no more then 10 testcases with n>100

For each testcase, the first line contains an integers n(1<=n<=100000), the length of S. And the second line contains a string of length S which only contains ‘(’ and ‘)’.
 

Output
For each testcase, print "Yes" or "No" in a line.
 

Sample Input
  
  
3 4 ())( 4 ()() 6 )))(((
 

Sample Output
  
  
Yes Yes No
Hint
For the second sample input, Rikka can choose (1,3) or (2,4) to swap. But do nothing is not allowed.
 

Author
学军中学
 

Source
 

题意:
给你一个括号串,让你必须交换一次,判断括号串是否匹配。必须!

POINT:
因为必须,所以单独拎出n=2且为()这种情况,显然是No。
我把左右括号不相等的情况也拎了出来,这样感觉比较好写。
其他情况:
如果一开始就是匹配的,交换后还是匹配。
如果一开始不匹配,就让第一个使串不匹配的)和最后一个(交换。这样还是没有匹配的话,就是No,反之Yes。
cnt[]数组是用来判断匹配的。赋值规则为:遇(加1,遇)减1,有小于0的肯定就不匹配了。
交换一次“)” “(”号,那么交换的区间内cnt[]全部加2 即多了一个左括号,少了一个右括号,总加2。若还有小于0的就是匹配不了。


#include <iostream>
#include <string.h>
#include <stdio.h>
#include <stack>
#include <algorithm>
#include <math.h>
using namespace std;
#define ll long long
const int N = 100000+4;
char s[N];
int cnt[N];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int now=0;
        int n;
        cin>>n;
        int flag=0;
        cin>>s;
        int you=999999;
        int zuo;
        int fz=0,fy=0;
        for(int i=0;i<n;i++)
        {
            if(s[i]=='(')
            {
                now++;
                zuo=i;
                fz++;
            }
            else now--,fy++;
            if(now<0&&!flag)
            {
                flag=1;
                you=i;
            }
            cnt[i]=now;
        }
        int ans=1;
        if(fz!=fy) ans=0;
        for(int i=you;ans&&i<=zuo;i++)
        {
            if(cnt[i]+2<0)
            {
                ans=0;
                break;
            }
        }
        if(strlen(s)==2&&s[0]=='('&&s[1]==')') printf("No\n");
        else if(!ans) printf("No\n");
        else printf("Yes\n");
    }
    
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值