ACdream 1020 - The Game about KILL(约瑟夫环)

10 篇文章 0 订阅

The Game about KILL

Time Limit: 2000/1000MS (Java/Others)  Memory Limit: 128000/64000KB (Java/Others)
Problem Description

Teacher HU and his 40 students were trapped by the brigands. To show their power, the head of the brigands want to select one people to kill.

Teacher HU and his 40 students will stand in a circle, and every second person would leave, and the last people in the circle would be killed.

For example, if there are 5 persons in the circle, counting proceeds as 2, 4, 1, 5 and person 3 will be killed.

To make his students alive, teacher HU calculated the position to be the last man standing, and sacrifice himself.

Now we consider a more common condition, if teacher HU has N - 1 students, which place should he stand to be the last person.

Input
There are multiple test cases.
Each test case only contains an integer  N. (1 ≤ N ≤ 1,000,000,000)
Output
For each test case, output an integer indicating which place should teacher HU stand.
Sample Input
2
3
Sample Output
1
3
Source
dut200901102
Manager




题意:

就是约瑟夫环。


找个规律就行。。


#include <iostream>
#include <string.h>
#include <math.h>
#include <algorithm>
#include <stdio.h>
using namespace std;
const int maxn = 100000+43;
const int inf = 0x3f3f3f3f;
#define LL long long

LL sum[maxn];

int main()
{
    LL n;
    int i;
    LL er=1;
    for(i=1;;i++){
        sum[i]=sum[i-1]+er;
        if(sum[i]>1000000000)
            break;
        er=2*er;
    }
    while(~scanf("%lld",&n)){
    	int now=lower_bound(sum,sum+1+i,n)-sum;
    //	printf("%d\n",now);
    	printf("%lld\n",-1+2*(n-sum[now-1]));
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值