ACdream1020:The Game about KILL

Problem Description
Teacher HU and his 40 students were trapped by the brigands. To show their power, the head of the brigands want to select one people to kill.
Teacher HU and his 40 students will stand in a circle, and every second person would leave, and the last people in the circle would be killed. For example, if there are 5 persons in the circle, counting proceeds as 2, 4, 1, 5 and person 3 will be killed. To make his students alive, teacher HU calculated the position to be the last man standing, and sacrifice himself.
Now we consider a more common condition, if teacher HU has N - 1 students, which place should he stand to be the last person.
Input
There are multiple test cases.
Each test case only contains an integer N. (1 <= N <= 1,000,000,000)
Output
For each test case, output an integer indicating which place should teacher HU stand.
Sample Input
2
3
Sample Output
1
3
 
 
约瑟夫环,n太大,首先可以想到打表找看有没有规律
可以发现时有规律的
可以看到,只要是2的i次幂,那么存活的是1,后面的依次加2
例如4为1,5就是3,6->5,7->7,8->1
 
 
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define ll long long
ll f[50],n;
 
int main()
{
    int i;
    f[0] = 1;
    for(i = 1; i<31; i++)
        f[i] = f[i-1]*2;
    while(~scanf("%lld",&n))
    {
        for(i = 1; i<31; i++)
        {
            if(n<f[i])
                break;
        }
        printf("%lld\n",1+2*(n-f[i-1]));
    }
 
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值