POJ_2488: A Knight's Journey

POJ_2488: A Knight's Journey

Description

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?


Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, .. .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:

A1


Scenario #2:

impossible


Scenario #3:

A1B3C1A2B4C2A3B1C3A4B2C4

题目:在一个n*m的格子里面,Knight从某一点出发,每次按照象棋中走“日”字的方法,判断他能否走完全部的格子。如果可以,按照字典序输出路径,如果不可以,输出”impossible“

分析:首先根据题目的意思,如果可以,Knight必定走完了所有的点,然后可以想到,我们从任意点出发,都能走完所有点,根据限制条件,按照字典序出发,于是我们可以从(1,1)点出发,有八个方向,考虑所有方向都可行并且按照字典序的话,方向的顺序应该为(-2,-1),(-2,1),(-1,-2),(-1,2),(1,-2)(1,2)(2,-1),(2,1),运用DFS,不断的递归求解,直至已走的点的数目等于n*m,说明有解,否则无解。在记录路径的时候,我考虑用两个数组来记录,一个记录X轴,一个记录Y轴,下标的变化过程跟已走的点数对应,并且需要用一个数组标记已走的点。具体贴代码吧~

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
int dir[8][2]={-2,-1,-2,1,-1,-2,-1,2,1,-2,1,2,2,-1,2,1};
int id[28][28];
int n,m;
int flag;
int letter[28];
int number[28];
void dfs(int x,int y,int count1)
{
    if(count1==n*m)
    {
        flag=true;
        return ;
    }
    for(int k=0;k<8;k++)
    {
        int x1=x+dir[k][0];
        int y1=y+dir[k][1];
        if(x1>=1&&x1<=m&&y1>=1&&y1<=n&&id[x1][y1]==0)
        {
            count1++;
            id[x1][y1]=1;
            letter[count1]=x1;
            number[count1]=y1;
            if(count1==n*m)
            {
                flag=true;
                return ;
            }
            dfs(x1,y1,count1);
            if(flag!=true)
            {
                id[x1][y1]=0;
                count1--;
            }
        }
    }
}
int main()
{
    int N;
    scanf("%d",&N);
    for(int h=1;h<=N;h++)
    {
        memset(id,0,sizeof(id));
        scanf("%d%d",&n,&m);
        flag=0;
        memset(letter,0,sizeof(letter));
        memset(number,0,sizeof(number));
        id[1][1]=1;
        letter[1]=1;
        number[1]=1;
        flag=false;
        dfs(1,1,1);
        int k=1;
        printf("Scenario #%d:\n",h);
        if(flag==true)
        {
            for(int i=1;i<=m*n;i++)
            {
                printf("%c%d",letter[i]-1+'A',number[i]);
            }
            printf("\n");
        }
        else
        {
            printf("impossible\n");
        }
        if(h!=N)
            printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值