POJ_3273_Monthly Expense

                       Monthly Expense
           Time Limit: 2000MS  Memory Limit: 65536K
           Total Submissions: 22908 Accepted: 8970

Description

Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called “fajomonths”. Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ’s goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.

Input

Line 1: Two space-separated integers: N and M
Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day
Output

Line 1: The smallest possible monthly limit Farmer John can afford to live with.
Sample Input

7 5
100
400
300
100
500
101
400
Sample Output

500
Hint

If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.
Source

USACO 2007 March Silver

题意不在此赘述,一道二分题

#include <iostream>
#include <iomanip>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <set>
#include <map>
#include <list>
#include <stack>
#include <deque>
#include <queue>
#include <vector>
#include <algorithm>
#include <functional>

#define debug(x) cout << "--------------> " << x << endl

using namespace std;

const double PI = acos(-1.0);
const double eps = 1e-10;
const long long INF = 0x7fffffff;
const long long MOD = 1000000007;
const int MAXN = 100888;

int a[MAXN];
int n, m;

int fun(long long M)
{
    int sum = 0, cnt = 1;
    for(int i = 0; i < n; ++i)
    {
        sum += a[i];
        if(sum > M)
        {
            cnt++;
            sum = a[i];
        }
    }
    return cnt;
}

int main()
{
    scanf("%d%d", &n, &m);
    long long sum = 0, Max = -1;
    for(int i = 0; i < n; ++i)
    {
        scanf("%lld", &a[i]);
        sum += a[i];
        if(a[i] > Max)
            Max = a[i];
    }

    long long l = Max, r = sum, mid;
    while(l <= r)
    {
        mid = (l+r) / 2;
        int k = fun(mid);
        if(k <= m)
            r = mid - 1;
        else
            l = mid + 1;
    }
    printf("%lld\n", mid);

    return 0;
}
 /************
   欢迎指正交流
    不胜感激!
 ************/
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值