二分法l例 E - Monthly Expenses1

E - Monthly Expense

armer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.

FJ wants to create a budget for a sequential set of exactly M (1 ≤ MN) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.

FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.


Input
Line 1: Two space-separated integers: N and M
Lines 2.. N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day
Output
Line 1: The smallest possible monthly limit Farmer John can afford to live with.
Sample Input
7 5
100
400
300
100
500
101
400
Sample Output
500
Hint
If Farmer John schedules the months so that the first two days are a month, the third and fourth are a month, and the last three are their own months, he spends at most $500 in any month. Any other method of scheduling gives a larger minimum monthly limit.


这个二分法

#include <iostream>

using namespace std;
const int maxn=100005;
int day[maxn];
int n,m;
int maxm;
int main()
{
    cin>>n>>m;
    for(int i=0;i<n;i++)
    cin>>day[i];
    int l=0,r=100000000;//二分寻找最小花费
    int mid;
    while(r>=l)
    {   mid=(r+l)/2;
        int mm=0,sum=0;
        for(int i=0;i<n;i++)
        {
            if(day[i]>mid)//如果单天消费超出总数,则证明此时的解太小,结束
            {sum=maxn;
             break;
            }
            if(mm+day[i]<=mid)//如果此时花费小于解
            {
                mm+=day[i];//花费增加
            }
           else//否则,进入下一个月,重新计算时间
            { sum++;
              mm=day[i];
             }

        }
        if(sum>=m)//如果天数太大,则说明解太小,注意此处等号,不能去掉
            l=mid+1;
        else
        {r=mid-1;
        }
    }
    cout<<l;//注意此处是l,不能写r
    return 0;
}



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值