Acperience
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 132 Accepted Submission(s): 61
Problem Description
Deep neural networks (DNN) have shown significant improvements in several application domains including computer vision and speech recognition. In computer vision, a particular type of DNN, known as Convolutional Neural Networks (CNN), have demonstrated state-of-the-art results in object recognition and detection.
Convolutional neural networks show reliable results on object recognition and detection that are useful in real world applications. Concurrent to the recent progress in recognition, interesting advancements have been happening in virtual reality (VR by Oculus), augmented reality (AR by HoloLens), and smart wearable devices. Putting these two pieces together, we argue that it is the right time to equip smart portable devices with the power of state-of-the-art recognition systems. However, CNN-based recognition systems need large amounts of memory and computational power. While they perform well on expensive, GPU-based machines, they are often unsuitable for smaller devices like cell phones and embedded electronics.
In order to simplify the networks, Professor Zhang tries to introduce simple, efficient, and accurate approximations to CNNs by binarizing the weights. Professor Zhang needs your help.
More specifically, you are given a weighted vector W=(w1,w2,…,wn). Professor Zhang would like to find a binary vector B=(b1,b2,…,bn) (bi∈{+1,−1}) and a scaling factor α≥0 in such a manner that ∥W−αB∥2 is minimum.
Note that ∥⋅∥ denotes the Euclidean norm (i.e. ∥X∥=x21+⋯+x2n−−−−−−−−−−−√, where X=(x1,x2,…,xn)).
Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains an integers n (1≤n≤100000) – the length of the vector. The next line contains n integers: w1,w2,…,wn (−10000≤wi≤10000).
Output
For each test case, output the minimum value of ∥W−αB∥2 as an irreducible fraction “p/q” where p, q are integers, q>0.
Sample Input
3
4
1 2 3 4
4
2 2 2 2
5
5 6 2 3 4
Sample Output
5/1
0/1
10/1
#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <iostream>
#define maxs 1000005
#define LL64 __int64
using namespace std;
int a[maxs];
LL64 gcd(LL64 aa,LL64 b)
{
if(b==0)
return aa;
if(aa<b)
swap(aa,b);
int t;
while(t=aa%b)
{
aa=b;
b=t;
}
return b;
}
LL64 abs(LL64 a)
{
if(a<0)
return -a;
return a;
}
int main()
{
int n,t;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
LL64 temp=0,sum=0,fenzi,fenmu;
for(int i=0;i<n;i++)
{
scanf("%d",&a[i]);
sum+=abs(a[i])*abs(a[i]);
temp+=abs(a[i]);
}
fenzi=sum*n-temp*temp;
fenmu=n;
if(fenzi==0)
{
printf("0/1\n");
}
else
{
LL64 temp=gcd(fenzi,fenmu);
printf("%I64d/%I64d\n",fenzi/temp,fenmu/temp);
}
}
return 0;
}