Hdu-5734 Acperience

43 篇文章 0 订阅
34 篇文章 0 订阅
Problem Description
Deep neural networks (DNN) have shown significant improvements in several application domains including computer vision and speech recognition. In computer vision, a particular type of DNN, known as Convolutional Neural Networks (CNN), have demonstrated state-of-the-art results in object recognition and detection.

Convolutional neural networks show reliable results on object recognition and detection that are useful in real world applications. Concurrent to the recent progress in recognition, interesting advancements have been happening in virtual reality (VR by Oculus), augmented reality (AR by HoloLens), and smart wearable devices. Putting these two pieces together, we argue that it is the right time to equip smart portable devices with the power of state-of-the-art recognition systems. However, CNN-based recognition systems need large amounts of memory and computational power. While they perform well on expensive, GPU-based machines, they are often unsuitable for smaller devices like cell phones and embedded electronics.

In order to simplify the networks, Professor Zhang tries to introduce simple, efficient, and accurate approximations to CNNs by binarizing the weights. Professor Zhang needs your help.

More specifically, you are given a weighted vector W=(w1,w2,...,wn) . Professor Zhang would like to find a binary vector B=(b1,b2,...,bn) (bi{+1,1}) and a scaling factor α0 in such a manner that WαB2 is minimum.

Note that denotes the Euclidean norm (i.e. X=x21++x2n , where X=(x1,x2,...,xn) ).
 

Input
There are multiple test cases. The first line of input contains an integer T , indicating the number of test cases. For each test case:

The first line contains an integers n (1n100000) -- the length of the vector. The next line contains n integers: w1,w2,...,wn (10000wi10000) .
 

Output
For each test case, output the minimum value of WαB2 as an irreducible fraction " p / q " where p , q are integers, q>0 .
 

Sample Input
  
  
3 4 1 2 3 4 4 2 2 2 2 5 5 6 2 3 4
 

Sample Output
  
  
5/1 0/1 10/1
 

Author
zimpha
 

Source
2016 Multi-University Training Contest 2

题意:给你一个n维向量,让你再找一个向量k*(±1,±1,±1,±1..,±1),使得这两个向量的和的模最小。


分析:若n维向量的各个坐标都为整数,那么k取平均值就可以了,注意到k前的正负号可以调整,所以当n的一个坐标为负数时对应的k也取负值就可以了,这样我们把原向量的
每个坐标都取绝对值就可以了。
 

#include <cstdio>
#include <queue>    
#include <vector>    
#include <cstdio>    
#include <utility>    
#include <cstring>    
#include <iostream>    
#include <algorithm>    
#define INF 0x3f3f3f3f
#define MOD 1000000007
using namespace std;
int T,n,a[100006];
long long gcd(long long a,long long b)
{
    if(a % b == 0) return b;
    return gcd(b,a % b);
}
int main()
{
    scanf("%d",&T);
    while(T--)
    {
        long long tot = 0,Tot = 0;
        scanf("%d",&n);
        for(int i = 1;i <= n;i++) 
        {
            scanf("%d",&a[i]);
            tot+=abs(a[i]);
            Tot+=1ll*a[i]*a[i];
        }
        long long UP = 1ll*n*Tot-tot*tot;
        if(UP == 0) cout<<"0/1"<<endl;
        else cout<<UP/gcd(UP,n)<<"/"<<n/gcd(UP,n)<<endl; 
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值