Red and Black
Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 37885 | Accepted: 20566 |
Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
Sample Output
45 59 6 13
Source
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
#define nsize 1010
int n, m;
int sum = 0;
int startx, starty;
int direction[4][2] = { {-1,0},{1,0},{0,-1},{0,1} };
char map[nsize][nsize];
bool visited[nsize][nsize];
void dfs(int x, int y) {
if (x < 0 || x >= n || y < 0 || y >= m) {
return;
}
if (map[x][y] == '#') {
return;
}
if (visited[x][y])
return;
visited[x][y] = true;
sum++;
for (int i = 0; i < 4; i++) {
int nx = x + direction[i][0];
int ny = y + direction[i][1];
dfs(nx, ny);
}
}
int main() {
while (cin >> m >> n, n + m) {
sum = 0;
memset(map, 0, sizeof(map));
memset(visited, 0, sizeof(visited));
for (int i = 0; i < n; i++) {
for (int j = 0; j < m; j++) {
cin >> map[i][j];
if (map[i][j] == '@') {
startx = i;
starty = j;
}
}
}
dfs(startx, starty);
cout << sum << endl;
}
}