HDU - 2222 Keywords Search(AC自动机模板题)

Keywords Search

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 67795    Accepted Submission(s): 22825


Problem Description
In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.
Wiskey also wants to bring this feature to his image retrieval system.
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.
 

Input
First line will contain one integer means how many cases will follow by.
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
Each keyword will only contains characters 'a'-'z', and the length will be not longer than 50.
The last line is the description, and the length will be not longer than 1000000.
 

Output
Print how many keywords are contained in the description.
 

Sample Input
  
  
1 5 she he say shr her yasherhs
 

Sample Output
  
  
3
 

Author
Wiskey
 

Recommend
lcy
 

Statistic |  Submit |  Discuss |  Note
#include <bits/stdc++.h>
using namespace std;

int t, n;
char s[101], f[1000001];
struct xx{
    int cnt;
    xx *fail;
    xx *nex[26];
    xx(){
        memset(nex, NULL, sizeof(nex));
        fail = NULL;
        cnt = 0;
    }
};

void Insert(xx *root, char a[]){
    int l = strlen(a);
    xx *p = root;
    for(int i = 0; i < l; i++){
        int id = a[i]-'a';
        if(p->nex[id] == NULL){
            p->nex[id] = new xx();
        }
        p = p->nex[id];
    }
    (p->cnt)++;
}

void bfs(xx *root){
    queue<xx*> k;
    root->fail = NULL;
    k.push(root);
    xx *p, *tmp;
    while(!k.empty()){
        tmp = k.front();
        k.pop();
        for(int i = 0; i < 26; i++){
            if(tmp->nex[i] != NULL){
                p = tmp->fail;
                while(p && !p->nex[i]){
                    p = p->fail;
                }
                if(!p) tmp->nex[i]->fail = root;
                else tmp->nex[i]->fail = p->nex[i];
                k.push(tmp->nex[i]);
            }
        }
    }
}

int AC_run(xx *root, char a[]){
    int l = strlen(a);
    int ans = 0;
    xx *p = root;
    for(int i = 0; i < l; i++){
        int id = a[i]-'a';
        while(!p->nex[id] && p != root){
            p = p->fail;
        }
        p = p->nex[id];
        if(!p) p = root;
        xx *tmp = p;
        while(tmp != root && tmp->cnt != -1){
            ans += tmp->cnt;
            tmp->cnt = -1;
            tmp = tmp->fail;
        }
    }
    return ans;
}

int main(){
    scanf("%d", &t);
    while(t--){
        scanf("%d", &n);
        xx *root = new xx();
        for(int i = 0; i < n; i++){
            scanf("%s", s);
            Insert(root, s);
        }
        bfs(root);
        scanf("%s", f);
        printf("%d\n", AC_run(root, f));
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值